11 Replies Latest reply on Apr 26, 2013 3:42 AM by Thomas Wiesner

    Can not debug OSGI Bundles deployed in JBoss EAP 6.1 with JBossTools 4.0.1/ JBoss Developer Studio 6&7

    Thomas Wiesner Newbie

      Hello All,

       

      while migrating from JBoss 7.1.1 to JBoss EAP 6.1 Alpha1, i've evaluated JBoss Tools 4.0.1, JBoss Developer Studio 6 & 7 Alpha1 with following issue.

       

      Our application consist of some osgi bundles and an osgi WAR which i can successfully publish and start with all named tools above. The only trick is, i've always to clean the data and tmp subdirectory in JBoss before start.

       

      After that i tried to start the JBoss in debug mode with the named tools and deploying/starting the bundles fails with the following exception:

       

      [0m [31m14:33:49,853 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-3) MSC00001: Failed to start service jboss.deployment.unit."de.xxx.yyy.data.services.jar".PARSE: org.jboss.msc.service.StartException in service jboss.deployment.unit."de.xxx.yyy.data.services.jar".PARSE: JBAS018733: Failed to process phase PARSE of deployment "de.xxx.yyy.data.services.jar"

          at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]

          at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]

          at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]

          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_05]

          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_05]

          at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_05]

      Caused by: java.lang.NullPointerException

          at org.jboss.as.osgi.service.FrameworkActivator.activate(FrameworkActivator.java:76)

          at org.jboss.as.osgi.deployment.FrameworkActivateProcessor.deploy(FrameworkActivateProcessor.java:72)

          at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120) [jboss-as-server-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]

          ... 5 more

       

      The same exception occurs for the other bundles.

       

      With all tools i've tried the jboss eap runtime 6.1 (tech preview) adapter, and also jboss eap runtime 6.0 adapter with the known work around to symlink the jboss-modules. I've got always the same exception.

       

      Can anybody give me a hint how to debug our application with jboss tools !? Or is it more a jboss eap 6.1 / jboss osgi issue !? But starting the jboss eap with standalone.sh and jboss tools "start" works fine with the deployed bundles.

       

      Please let me know if you need further information.

       

      Kind regards, Thomas