2 Replies Latest reply on Aug 16, 2013 11:53 AM by Sergey Morenets

    rich:tooltip issue

    Sergey Morenets Novice

      Hi

       

      I tried to attach tooltip to a4j:commandLink. It works fine if mode is "client". If mode is "ajax" then commandLink

      stops working. No request is made to the server-side

       

      <a4j:commandLink action="#{linkController.addFavorite(bean)}">
      <h:graphicImage url="/resources/images/add.png"
      />
      <rich:tooltip direction="topRight" mode="ajax" showDelay="400"
      styleClass="tooltip" layout="block">
      <h:outputText value="#{msg['favorite.add']}" />
      </rich:tooltip>
      </a4j:commandLink>

       

       

       

      RichFaces 4.3.1

        • 1. Re: rich:tooltip issue
          Juraj Húska Master

          Hi Sergey,

           

          I was able to define an ajax tooltip over a4j:commandLink with

          RichFaces 4.3.1

          and Chrome 26, Firefox 20

          and Tomcat 7 or JBoss AS 7.1.1.Final

           

          What is your environment ?

           

          This code worked for me:

           

          <h:form>

                      <a4j:commandLink value="Say Hello" render="out" execute="@form">

                          <h:graphicImage url="/images/nature/pic1.jpg"/>

                          <rich:tooltip direction="topRight" mode="ajax" showdelay="400" layout="block">

                              <h:outputText value="#{userBean.name}"/>

                          </rich:tooltip>

                      </a4j:commandLink>

          </h:form>

          1 of 1 people found this helpful
          • 2. Re: rich:tooltip issue
            Sergey Morenets Novice

            Hi, Juraj

             

            Thank you for the update.

            I upgraded my configuration and "ajax" mode works properly now.

             

            RichFaces 4.3.3

            JSF 2.1.25