2 Replies Latest reply on Sep 16, 2013 5:56 AM by Miloslav Havrda

    problem with running sample = evaluation

    Mahdi k Newbie

      hi ,

      i tried to run JBPM 5.4 evaluation sample . after running ProcessTest.java in eclipse this line is written in console :

       

      process started ...

       

      when i go to the human task view in eclipse , and write "krisv" in UserId and click on the Refresh button , eclipse says :

       

      Exception during refresh:Server-side Exception:command. QueryTaskAssignedAsPotentialOwner failed due to operation failed. Please contact task server administrator.

       

      when i went to my server log , i found some errors there . i have attached the server log.

       

      *****more details******

       

      role.properties: 

       

      admin=admin,manager,user,webdesigner,functionalanalyst

      krisv=admin,manager,user

      john=admin,manager,user,PM

      mary=admin,manager,user,HR

      sales-rep=admin,manager,user,sales

       

      users.properties:

       

      admin=admin

      krisv=krisv

      john=john

      mary=mary

      sales-rep=sales-rep

        • 1. Re: problem with running sample = evaluation
          irs Newbie

          Hi

           

          I went through the server.log provided by you and found the following exception.

           

          "Caused by: javax.persistence.PersistenceException: org.hibernate.exception.ConstraintViolationException: Unique index or primary key violation: "PRIMARY_KEY_C ON PUBLIC.ORGANIZATIONALENTITY(ID)"; SQL statement:

          insert into OrganizationalEntity (DTYPE, id) values ('Group', ?) [23505-161]"

           

          This exception occurs when you have some duplicate entries in your ORGANIZATIONALENTITY schema. so you can chekout your ORGANIZATIONALENTITY schema. Usualy happens with the admin user.

           

          Regards Irshad

          • 2. Re: problem with running sample = evaluation
            Miloslav Havrda Newbie

            I had the same problem in jBPM 6.0 CR2.

            Try to run ant clean.db from build.xml file.

            It solved my problem.