1 Reply Latest reply on Apr 24, 2013 4:40 AM by Wolf-Dieter Fink

    Getting exception User null not authenticated on Jboss startup

    Srinithya R Newbie

      Hi

       

      We are using JBOSS 4.0.1 in our application.

       

      While starting up JBoss, the following exception occurs in server.log file:

       

      ERROR [org.jboss.jdbc.HypersonicDatabase] Starting failed jboss:service=Hypersonic,database=localDB

      java.sql.SQLException: General error: java.lang.NullPointerException

       

      and at later point there is exception like:

      Initialization failed DLQHandler

      javax.jms.JMSSecurotyException: User: null is NOT authenticated

       

      To add to the above exceptions, what is noted is, the localDB.script file is corrupt (blank file but with size 3KB)

       

      I searched a lot for a solution to this problem. Many suggest to remove the contents of the server/default/data/hypersonic folder and restart JBOSS. But this doesn't seem to help.

      When i removed the files in hypersonic folder and restarted JBOSS, the script file was created again but with minimal statements which ultimately led to another exception like : JMS_ROLES table not found.

      also it was noticed that localdb.data file was not created after restart.

       

      What i understand from all these is that the hypersonic DB is corrupt or crashed and is not recovering during Jboss restart. I am clueless as to What made this crash.

       

      Can anyone help me in understanding how these localDB.script file is created each time? Because I feel if the script file is created completely, then issue may get solved.

        • 1. Re: Getting exception User null not authenticated on Jboss startup
          Wolf-Dieter Fink Master

          Hello Srinithya,

          welcome to the forum.

           

          That's a really old version.

          In general hypersonic is not a DB to use in production.

           

          If you have a default configuration the hsqldb is used for ejb-timer and jms persistence. You might remove that and use a different DB if possible.

          But normaly the hsqldb library will build the DB from scratch and that should work.

          Do you have tried a fresh unzipped JBoss, this should create the DB and you might verify the configuration differences.