0 Replies Latest reply on May 6, 2013 9:10 AM by Sueleyman Vurucu

    JBoss 6.1.0.Beta Confusion over Configuration??

    Sueleyman Vurucu Expert

      Hi,

       

      I try to update my project from JBoss 6.1.0.Alpha to 6.1.0.Beta. For that I add http://maven.repository.redhat.com/techpreview/eap6/6.1.0.Beta1/ as proxy to our local nexus server.

       

      Up to dom4j-1.6.1-redhat-5 everything found my maven. hibernate-core looks for a version 1.6.1-redhat-4 which is not located in http://maven.repository.redhat.com/techpreview/eap6/6.1.0.Beta1/ its located in http://maven.repository.redhat.com/techpreview/eap6/6.1.0.Alpha1. So I have to add this repo too ??

       

      So I have several questions:

       

      1. JBoss 6.1.0.Alpha is realted on 7.2.0.Final. What about JBoss 6.1.0.Beta?? On which opensource version is that related ?

      2. Why I have to add a maven repository for every JBoss version ??

      3. The roadmap of wildfly list several versions of opensource branch. If I wait for 8.0.0.Alpha1 for example. Will then the artifacts hosted in public jboss repo or at http://maven.repository.redhat.com/techpreview/eap6/<next-version>.

      4. 6.1.0.Beta use for its' dependecies a "redhat-x" suffix. I assume that this a manner unique for identyfy the artifacts. For hibernate core for example hibernate-core-4.2.0.Final-redhat-1. It's recommended to use this version too in the projects' pom ? Or can I use the version 4.2.0.Final instead of 4.2.0.Final-redhat-1 with a peace of conscience.

      5. What about jboss versuion for arquillian ?