8 Replies Latest reply on May 23, 2013 9:02 AM by William Bertan

    Sometimes JBOSS 7.1.1 start with error

    William Bertan Newbie

      Hi,

       

      I use JBOSS in our client-side application, all works fine and very well, thanks to the JBOSS!

       

      But sometimes, only a few times really, the JBOSS in the services.msc shows like started and fine, but in the log show this:

       

      2013-05-09 08:19:46,741 INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report

      JBAS014777:   Services which failed to start:      service jboss.network.management: org.jboss.msc.service.StartException in service jboss.network.management: Failed to start service

            service jboss.network.public: org.jboss.msc.service.StartException in service jboss.network.public: Failed to start service

       

       

      2013-05-09 08:19:48,475 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015954: Admin console is not enabled

      2013-05-09 08:19:48,475 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: JBoss AS 7.1.1.Final "Brontes" started (with errors) in 44522ms - Started 1215 of 1312 services (45 services failed or missing dependencies, 51 services are passive or on-demand)

       

      And I can't know that happening unless I connect the client server and look into the log file. When this happens, I can't use any of my webservices, neither the Management and the Welcome Page.

       

      I've tried a lot of workarounds to try to discover the error, some of my tries ended in the standalone.xml configuration to the management interface, so I'm configuring like this:

       

              <interface name="management">

                  <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>

              </interface>

       

      If I'm not wrong this is the default... And I'm in a dead end now... I'm on this for a few days until now and my supervisors are asking me for a solution, because we had a problem with a client that "showed" the status OK (service status), but in the background he doesn't sync...

       

      I would appreciate any help. Thank you for the attention and sorry for any mistake about my English

        • 1. Re: Sometimes JBOSS 7.1.1 start with error
          Wolf-Dieter Fink Master

          If the start failed do you see other errors or warnings in the logfile before the JBAS014774?

          1 of 1 people found this helpful
          • 2. Re: Sometimes JBOSS 7.1.1 start with error
            William Bertan Newbie

            Hi,

             

            Thank you for the reply.

             

            You right, before that message it was those errors:

             

            2013-05-09 08:19:17,000 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.network.public: org.jboss.msc.service.StartException in service jboss.network.public: Failed to start service

                      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_02]

                      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_02]

                      at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_02]

            Caused by: java.lang.Error: IP Helper Library GetAdaptersAddresses function failed

                      at java.net.NetworkInterface.getAll(Native Method) [rt.jar:1.7.0_02]

                      at java.net.NetworkInterface.getNetworkInterfaces(NetworkInterface.java:326) [rt.jar:1.7.0_02]

                      at org.jboss.as.server.services.net.NetworkInterfaceService.resolveInterface(NetworkInterfaceService.java:135) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                      at org.jboss.as.server.services.net.NetworkInterfaceService.createBinding(NetworkInterfaceService.java:117) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                      at org.jboss.as.server.services.net.NetworkInterfaceService.start(NetworkInterfaceService.java:92) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                      ... 3 more

             

             

            2013-05-09 08:19:17,187 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC00001: Failed to start service jboss.network.management: org.jboss.msc.service.StartException in service jboss.network.management: Failed to start service

                      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_02]

                      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_02]

                      at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_02]

            Caused by: java.lang.Error: IP Helper Library GetAdaptersAddresses function failed

                      at java.net.NetworkInterface.getAll(Native Method) [rt.jar:1.7.0_02]

                      at java.net.NetworkInterface.getNetworkInterfaces(NetworkInterface.java:326) [rt.jar:1.7.0_02]

                      at org.jboss.as.server.services.net.NetworkInterfaceService.resolveInterface(NetworkInterfaceService.java:135) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                      at org.jboss.as.server.services.net.NetworkInterfaceService.createBinding(NetworkInterfaceService.java:117) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                      at org.jboss.as.server.services.net.NetworkInterfaceService.start(NetworkInterfaceService.java:92) [jboss-as-server-7.1.1.Final.jar:7.1.1.Final]

                      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                      ... 3 more

             

            I will do more research with those news, and I would appreciate any help.

             

            Thank you!

            • 3. Re: Sometimes JBOSS 7.1.1 start with error
              Nicklas Karlsson Master

              Caused by: java.lang.Error: IP Helper Library GetAdaptersAddresses function failed

                        at java.net.NetworkInterface.getAll(Native Method) [rt.jar:1.7.0_02]

               

              Window host with a mixed ipv4/ipv6 networking? Virtual server?

              • 4. Re: Sometimes JBOSS 7.1.1 start with error
                William Bertan Newbie

                Hello,

                 

                Thank you for the reply.

                 

                No, some client servers are Windows Server 2008/2003, but we have servers running on Windows XP and Windows 7 too.

                 

                We got this error once in Windows Server 2008 and in Windows XP so far.

                 

                Both machines working only with IPV4 and not running virtual servers.

                 

                I can't find any solution for this.

                 

                I'm starting to think, maybe it's a bug? Because when the JBOSS start with this error (sometimes only) and I restart the JBOSS (not the machine, only the JBOSS), the server starts fine...

                • 5. Re: Sometimes JBOSS 7.1.1 start with error
                  Nicklas Karlsson Master

                  64bit hosts? JRockit or Sun JDK? The errors comes pretty deep from the JDK/dll:s so I wouldn't call it a bug just yet.

                  • 6. Re: Sometimes JBOSS 7.1.1 start with error
                    William Bertan Newbie

                    Ok,

                     

                    We have servers in 32 and 64 bits, and the problem we have, occured in one machine Windows XP 32 bits, and in another Windows Server 2008 64bits :/

                     

                    Both using Sun JDK, one portable installation, actually we copy the jdk folder inside our JBOSS folder and all the references go to the absolute path. We don't put in the CLASSPATH neither in JAVA_PATH, actualy we don't put nothing in environment variables...

                    • 7. Re: Sometimes JBOSS 7.1.1 start with error
                      Nicklas Karlsson Master

                      Have you tried with a later 1.7.0_x ?

                      • 8. Re: Sometimes JBOSS 7.1.1 start with error
                        William Bertan Newbie

                        Hi,

                         

                        I will upgrade the java in our clients, and see if it's happens again.

                         

                        Thank you for the advice!

                         

                        I will keep the post posted

                         

                        << EDIT >>

                         

                        Well, so far, I didn't get this error, maybe this was the problem!

                         

                        I will keep checking the start of the service every day.

                         

                        And now I'm getting another problem in a new client, but that's, if I didn't solve, another thread