7 Replies Latest reply on May 15, 2013 12:32 AM by Arun Raj

    Can not upload Plugin in RHQ 4.6

    Arun Raj Expert

      Hi RHQ Team,

       

          Tried to upload Plugins in RHQ 4.6. We getting "File uploaded successfully" in the GUI. But it is not logged in Agent. Please check it out.

       

          But when we tried to paste the plugin in plugins directory, It is working fine.

       

         Please check this issue.

       

      Regards,

      ArunRaj

        • 1. Re: Can not upload Plugin in RHQ 4.6
          Thomas Segismont Expert

          Hi,

           

          This is expected, the agent does not download new versions of its plugins as soon as they are uploaded to the server.

           

          • If you run your agent in console mode, you can execute the "plugins update" command
          • If you imported your agent as a resource in RHQ, you can invoke the "updatePlugins" operation
          • Plugins will get updated if you restart your agent and didn't change the value of the default agent configuration property "rhq.agent.update-plugins-at-startup"

           

          Here is an extract of the agent configuration file:

           

           

                         <!--
                         _______________________________________________________________
                         rhq.agent.update-plugins-at-startup
          
          
                         If true, the agent will attempt to update its current set
                         of plugins to their latest versions at startup. If false, the
                         agent will not automatically update the plugins; the agent
                         will use its current plugins.  To update the plugins, you must
                         manually do so via some other mechanism (e.g. the
                         'plugins' prompt command).
                         Note that even if this is true, the update may not happen
                         immediately if the RHQ Server itself is not up - once the RHQ
                         Server comes up, the update attempt will occur.
                         -->
                         <entry key="rhq.agent.update-plugins-at-startup" value="true" />
          
          

           

          Regards,

          Thomas

          • 3. Re: Can not upload Plugin in RHQ 4.6
            Arun Raj Expert

            Hi Guys,

             

                Extremely sorry for posting my question in a confusion manner.

             

                My Problem is UPLOADING a plugin to a server, NOT in a RHQ Agent. When I have hitted UPLOAD Button, GUI says "File has been successfully uploaded". But Actually, There is nothing has been uploaded into plugins folder of RHQ Server.

             

                If I have put the file in the plugins folder, Then everything is fine.

             

            Regards,

            ArunRaj

            • 4. Re: Can not upload Plugin in RHQ 4.6
              mazz Master

              On the server, there is the plugin dropbox directory (found at <rhq-server-install-dir>/plugins). This is just a temporary location and it is here for users to easily remember where plugins go. When you upload plugins (server plugins or agent plugins), the RHQ Server will also put them in the /plugins directory. However, once the plugin scanner runs, the files are removed from there.  So don't expect that plugins directory to remain full - it will eventually empty out when the plugin scanner runs and fully deployed the plugins it found in there.

               

              The question you really care about is -- did your plugin get installed properly? Go in Administration>AgentPlugins and look in the list. If you see your plugin, you're good. Don't worry about what is in the /plugins directory.

               

              For more: https://docs.jboss.org/author/display/RHQ/Agent+Plugin+Administration

              • 5. Re: Can not upload Plugin in RHQ 4.6
                jay shaughnessy Expert

                Just to be clear, <rhq-server-install-dir>/plugins is not a destination directory for installed plugins.  When you say, "There is nothing has been uploaded into plugins folder" after a successful upload, that is to be expected.  That directory is for installing plugins only. Installed plugins are stored in the DB.  As mazz says, refresh the Agent Plugins list in the gui and you should see the uploaded plugin.  Once it is there you can get it to the agent via a restart, or by executing the plugins update agent prompt command.

                • 6. Re: Can not upload Plugin in RHQ 4.6
                  Arun Raj Expert

                  Hi John,

                   

                      Thanks for your guidance.

                   

                  Regards,

                  ArunRaj

                  • 7. Re: Can not upload Plugin in RHQ 4.6
                    Arun Raj Expert

                    Hi Jay,

                     

                        Thanks for your guidance.

                     

                    Regards,

                    ArunRaj