3 Replies Latest reply on May 30, 2013 4:19 AM by Gary Brown

    Error starting the parser

    okta io Newbie

      Hello,

       

      When I try to run the sample, I get the following error:

       

      c:\Users\okta\Downloads\scribble-tools-cli-2.0.0.Final\bin>parse.bat Purchasing.spr

      ERROR: Error starting file:/c:/Users/okta/Downloads/scribble-tools-cli-2.0.0.Final/bundle/org.scribble.command.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.scribble.com

      mand [3]: Unable to resolve 3.0: missing requirement [3.0] package; (package=org.scribble.protocol.monitor) - [3.0] package; (package=org.scribble.protocol.monitor))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.scribble.command [3]: Unable to resolve 3.0: missing requirement [3.0] package; (package=org.scribble.protocol.monitor) - [3.0]

      package; (package=org.scribble.protocol.monitor)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3421)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1754)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1188)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Unknown Source)

      ERROR: Error starting file:/c:/Users/okta/Downloads/scribble-tools-cli-2.0.0.Final/bundle/org.scribble.protocol.export.monitor.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle

      org.scribble.protocol.export.monitor [6]: Unable to resolve 6.0: missing requirement [6.0] module; (bundle-symbolic-name=org.scribble.protocol.monitor) - [6.0] module; (bundle-symbolic-name=org.scribb

      le.protocol.monitor))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.scribble.protocol.export.monitor [6]: Unable to resolve 6.0: missing requirement [6.0] module; (bundle-symbolic-name=org.scribbl

      e.protocol.monitor) - [6.0] module; (bundle-symbolic-name=org.scribble.protocol.monitor)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3421)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1754)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1188)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Unknown Source)

      ERROR: Error starting file:/c:/Users/okta/Downloads/scribble-tools-cli-2.0.0.Final/bundle/org.scribble.protocol.monitor.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.scr

      ibble.protocol.monitor [8]: Unable to resolve 8.0: missing requirement [8.0] package; (package=javax.xml.bind) - [8.0] package; (package=javax.xml.bind))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.scribble.protocol.monitor [8]: Unable to resolve 8.0: missing requirement [8.0] package; (package=javax.xml.bind) - [8.0] packag

      e; (package=javax.xml.bind)

              at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3421)

              at org.apache.felix.framework.Felix.startBundle(Felix.java:1754)

              at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1188)

              at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)

              at java.lang.Thread.run(Unknown Source)

      Command not executed

       

       

      I tried this on both Windows 7 and Ubunut12.04, and I get the same error.

      I have jdk 1.7.0_14 x64 installed, and for the command above, the file 'Purchasing.spr' was placed in the /bin directory.

      Can you tell me what is wrong?

       

      Thanks!

        • 1. Re: Error starting the parser
          Gary Brown Master

          Hi

           

          This looks to be a JDK7 issue. If you try running the same commands using JDK6 it should work ok. You might also want to try out the Eclipse plugins.

           

          It is unlikely that further work will be done on this version of Scribble, which was based on a version of the language which did not have strong type theory for all of the constructs.

           

          Work is currently under way at Imperial University and Queen Mary University to define a revised version of the language that does have a strong type theory. This will form the basis of version 3 of the tools.

           

          Regards

          Gary

          • 2. Re: Error starting the parser
            okta io Newbie

            Hi Gary,

             

            Thanks for the response. It solved the problem.

             

            From what I saw, the current version does not support multi-party communication(i,e. one role cannot communicate with other roles except the one that introduced it).

            Is there any chance that this feature will be available in the next version?

             

            Thanks!

            • 3. Re: Error starting the parser
              Gary Brown Master

              Hi Okta

               

              The language does support multi-party communications - you simply need to introduce multiple roles. However you are correct that a role can only communicate with either the role that introduced it, or the roles it introduces. There is no support for role passing currently.

               

              If you have specific requirements, now is a good time to discuss them with the team working on the new version of the language. Best thing would be to post your requirements/questions to this group: https://groups.google.com/forum/#!forum/scribble-lang

               

              Its a new group, so doesn't have much traffic yet.

               

              Regards

              Gary