2 Replies Latest reply on May 28, 2013 10:20 AM by Jose Miguel Loor

    Problem with the soa-p 5.3.1 integration with jbpm 5

    Jose Miguel Loor Apprentice

      hi

       

      I have a running jboss esb (soa-p-5.3.1.GA) with jbpm 3. I was able to test it with a bpm process, called via esb actions and services. It is working fine

       

      Now, i am trying to test the jbpm 5 integration. Downloaded the soa-p-5.3.1.GA-jbpm5.zip file, and followed the instructions (using the brms-p-5.3.1.GA-deployable.zip from jbpm), but it is not deploying fine.

       

      In the server log i am seeing this errors:

       

      DEPLOYMENTS IN ERROR:

        Deployment "persistence.unit:unitName=jbpm-human-task.war#org.jbpm.task" is in error due to the following reason(s): org.xml.sax.SAXParseException; lineNumber: 5; columnNumber: 32; cvc-complex-type.3.1: Value '2.0' of attribute 'version' of element 'entity-mappings' is not valid with respect to the corresponding attribute use. Attribute 'version' has a fixed value of '1.0'.

        Deployment "persistence.unit:unitName=business-central-server.war#org.jbpm.persistence.jpa" is in error due to the following reason(s): org.xml.sax.SAXParseException; lineNumber: 5; columnNumber: 32; cvc-complex-type.3.1: Value '2.0' of attribute 'version' of element 'entity-mappings' is not valid with respect to the corresponding attribute use. Attribute 'version' has a fixed value of '1.0'.

       

      I am guessing that these errors are being caused by the hibernate version of the soa-p. So, how do i correct this ? do i need to upgrade the hibernate version ? Why is this not mentioned in the documentation ??