5 Replies Latest reply on Jun 14, 2013 4:53 AM by Petr Mensik

    Not able to run Arquillian Drone tests on Jenkins

    Petr Mensik Newbie

      Hello guys,

       

      I am using Arquillian with Drone to perform functional testing. Everything is working just fine when I run tests on my local machine. But unfurtunately that doesn't apply if I try to run them in the Jenkins on some remote machine, I always get this exception

       

      java.lang.RuntimeException: Could not invoke deployment method: public static org.jboss.shrinkwrap.api.spec.WebArchive org.gatein.test.AbstractWebDriverTest.createDeployment()

              at org.jboss.shrinkwrap.api.ClassLoaderSearchUtil.findClassFromClassLoaders(ClassLoaderSearchUtil.java:86)

              at org.jboss.shrinkwrap.api.ConfigurationBuilder.createDefaultExtensionLoader(ConfigurationBuilder.java:222)

       

      Full stack trace here here.

       

      My dependencies are

       

      <dependencyManagement>

              <dependencies>

                  <dependency>

                      <groupId>org.jboss.arquillian.selenium</groupId>

                      <artifactId>selenium-bom</artifactId>

                      <version>2.32.0</version>

                      <type>pom</type>

                      <scope>import</scope>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.arquillian</groupId>

                      <artifactId>arquillian-bom</artifactId>

                      <version>1.0.3.Final</version>

                      <type>pom</type>

                      <scope>import</scope>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.arquillian.extension</groupId>

                      <artifactId>arquillian-drone-bom</artifactId>

                      <version>1.2.0.Alpha1</version>

                      <type>pom</type>

                      <scope>import</scope>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.arquillian.graphene</groupId>

                      <artifactId>graphene-webdriver</artifactId>

                      <version>2.0.0.Alpha3</version>

                      <type>pom</type>

                      <scope>test</scope>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.as</groupId>

                      <artifactId>jboss-as-arquillian-container-remote</artifactId>

                      <version>7.1.3.Final</version>

                  </dependency>

                  <dependency>

                      <groupId>org.testng</groupId>

                      <artifactId>testng</artifactId>

                      <version>6.8</version>

                  </dependency>

             </dependencies>

      </dependencyManagement>

       

      <dependencies>

              <dependency>

                  <groupId>org.testng</groupId>

                  <artifactId>testng</artifactId>

                  <scope>test</scope>

              </dependency>

              <dependency>

                  <groupId>org.jboss.arquillian.testng</groupId>

                  <artifactId>arquillian-testng-container</artifactId>

                  <scope>provided</scope>

              </dependency>

              <dependency>

                  <groupId>org.jboss.arquillian.extension</groupId>

                  <artifactId>arquillian-drone-impl</artifactId>

                  <scope>test</scope>

              </dependency>

              <dependency>

                  <groupId>org.jboss.arquillian.extension</groupId>

                  <artifactId>arquillian-drone-webdriver</artifactId>

                  <scope>test</scope>

              </dependency>

              <dependency>

                  <groupId>org.jboss.arquillian.graphene</groupId>

                  <artifactId>graphene-webdriver</artifactId>

                  <type>pom</type>

                  <scope>test</scope>

              </dependency>

      </dependency>

       

      <profile>

           <id>jbossportal-remote-7-1</id>

           <activation>

               <activeByDefault>true</activeByDefault>

           </activation>

           <dependencies>

                <dependency>

                      <groupId>org.jboss.as</groupId>

                      <artifactId>jboss-as-arquillian-container-remote</artifactId>

                 </dependency>

           </dependencies>

      </profile>

       

      And my setup is really simple

       

          @ArquillianResource

          private URL contextRoot;

         

          @Drone

          protected WebDriver driver;

         

          @Deployment(testable = false)

          public static WebArchive createDeployment() {

              return ShrinkWrap.createFromZipFile(WebArchive.class, new File("target/project.war"));

          }

       

      I am getting really desperate about this issue, I have even deleted whole .m2 folder on my local machine so I could try if I am really missing some dependency and Maven succesfully downladed and ran all the tests, so I don't really get why this won't work on Jenkins.

       

      Thanks for any tips!