0 Replies Latest reply on May 30, 2013 2:55 PM by elazaar mohamed

    Springwebflow + CDI + JSF application on Jboss 7

    elazaar mohamed Newbie

      I have been trying to get my application working under JBoss 7 but have finally hit a problem that I cannot find an answer to.

      The application is a web based application using springwebflow,cdi,jsf (primefaces).

      it gets deployed without an error and renders the first page (login.xhtml). once i'm logged in, if i try to click list of accounts (users's accounts) link (which invokes the webflow for list of Accounts) which display a list of accounts but when the server looks for the resource to use for rendering the view, it fails withFileNotFoundException when attempting to load a resource as below. javax.faces.FacesException: Error Checking Last Modified for jndi:/localhost/datapTest/AccountSelect.xhtml For some reason the default view of the flow (Accountflow) is being converted to a jndi resource location. Can anybody help?

      after changing the param javax.faces.FACELETS_REFRESH_PERIOD value to 1 exception :Caused by: javax.faces.FacesException: java.io.FileNotFoundException: Facelet /accountSelect.xhtml not found at: jndi:/default-host/datapTest/accountSelect.xhtml

      when i use  glassfish this problem is not encountered at all , it works fine + i've tried more than 4 versions of jboss (7.0,7.1.0,6.1 eap) still the same exception is thrown.