8 Replies Latest reply on Jun 7, 2013 4:51 AM by Unice Gwe Mbuamuh

    rt.jar NoClassDefFoundError: javax/xml/parsers/ParserConfigurationException

    Unice Gwe Mbuamuh Newbie

      I am having the following exception at server startup, when it starts up a service i implemented:

       

      at  org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server-7.2.0.Final-redhat-4.jar:7.2.0.Final-redhat-4]

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]

              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:895) [rt.jar:1.6.0_41]

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:918) [rt.jar:1.6.0_41]

              at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_41]

      Caused by: java.lang.NoClassDefFoundError: javax/xml/parsers/ParserConfigurationException

              at java.lang.Class.getDeclaredConstructors0(Native Method) [rt.jar:1.6.0_41]

              at java.lang.Class.privateGetDeclaredConstructors(Class.java:2398) [rt.jar:1.6.0_41]

              at java.lang.Class.getConstructor0(Class.java:2708) [rt.jar:1.6.0_41]

              at java.lang.Class.newInstance0(Class.java:328) [rt.jar:1.6.0_41]

              at java.lang.Class.newInstance(Class.java:310) [rt.jar:1.6.0_41]

              at org.jboss.common.beans.property.finder.DefaultPropertyEditorFinder.find(DefaultPropertyEditorFinder.java:187)

              at org.jboss.as.service.ParsedServiceDeploymentProcessor.newValue(ParsedServiceDeploymentProcessor.java:219)

              at org.jboss.as.service.ParsedServiceDeploymentProcessor.getValue(ParsedServiceDeploymentProcessor.java:189)

              at org.jboss.as.service.ParsedServiceDeploymentProcessor.addServices(ParsedServiceDeploymentProcessor.java:143)

              at org.jboss.as.service.ParsedServiceDeploymentProcessor.deploy(ParsedServiceDeploymentProcessor.java:103)

      at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120) [jboss-as-server-7.2.0.Final-redhat-4.jar:7.2.0.Final-redhat-4]

              ... 5 more

      Caused by: java.lang.ClassNotFoundException: javax.xml.parsers.ParserConfigurationException from [Module "org.jboss.common-beans:main" from local module loader @48ee22f7 (finder: local module finder @a39ab89 (roots: C:\project\jboss-eap-6.1Beta\modules,C:\project\jboss-eap-6.1Beta\modules\system\layers\base))]

              at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190) [jboss-modules.jar:1.2.0.CR1-redhat-1]

      at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468) [jboss-modules.jar:1.2.0.CR1-redhat-1]

              at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456) [jboss-modules.jar:1.2.0.CR1-redhat-1]

              at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423) [jboss-modules.jar:1.2.0.CR1-redhat-1]

              at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398) [jboss-modules.jar:1.2.0.CR1-redhat-1]

              at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120) [jboss-modules.jar:1.2.0.CR1-redhat-1]

              ... 16 more

       

       

       

       

       

       

      I have updated the module sun.jdk adding the package  javax/xml/parsers as adviced in the thread http://stackoverflow.com/questions/11745871/as7-classnotfoundexception-despite-updated-sun-jdk-module-xml-and-ears-manifes

      but i still get the same exception? Can you please advice on this? Thank you