1 Reply Latest reply on Jun 7, 2013 2:05 AM by Wolf-Dieter Fink

    eap6.1 and as6, hornet jms port 5445

    John Franey Novice

      We have two clusters, one based on as6 - the other eap6.1, running on the same lan.

       

      When the domain controller of the eap6.1 is running, we see on the as6 side, MUCH too frequently:

       

      2013-06-06 16:39:43,653 WARN  [org.hornetq.core.protocol.core.impl.HornetQPacketHandler] (Old I/O server worker (parentId: 11724690, channelId:

      6173441, null => /10.133.143.21:5445)) Client with version 123 and address /10.133.143.5:50735 is not compatible with server version 2.1.2.Final

      (Colmeia, 120). Please ensure all clients and servers are upgraded to the same version for them to interoperate properly

      2013-06-06 16:39:43,654 ERROR [org.hornetq.core.protocol.core.impl.HornetQPacketHandler] (Old I/O server worker (parentId: 11724690, channelId:

      6173441, null => /10.133.143.21:5445)) Failed to create session : HornetQException[errorCode=108 message=Server and client versions incompatible

      ]

       

       

      We tried changing the domain.xml file to change socket binding of messaging port to something other than 5445, but to no effect.

       

      What do we have to change on the eap6.1 side to prevent it from sending to the as6 server?

       

      Thanks

        • 1. Re: eap6.1 and as6, hornet jms port 5445
          Wolf-Dieter Fink Master

          As I know the cluster function in HornetQ is separate from the other HA.

          So you should change

            <socket-binding name="messaging-group" port="0" multicast-address="${jboss.messaging.group.address:231.7.7.7}" multicast-port="${jboss.messaging.group.port:9876}"/>

          or set the system properties in the server-group configuration to change the multicast address and port.