0 Replies Latest reply on Jun 10, 2013 7:35 AM by Andrew Bowley

    JAX-RS Tutorial needs update?

    Andrew Bowley Newbie

      Link: https://docs.jboss.org/author/display/AS71/Java+API+for+RESTful+Web+Services+%28JAX-RS%29

       

      Hi

       

      This is an excellent tutorial but maybe in need of a revision as I had to keep making adjustments as I went along because the details were out of date.

       

      I admit I used had jboss-as-7.1.1.Final instead of jboss-as-7.0.1.Final, but I naturally did not want to go backwords.

       

      Here are the adjustiments:

       

      The javaee-tutorial pom.xml properties needed to be updated for jboss-as-7.1.1 and some of it's dependencies (took a while to resolve)
      The arqillian.xml configuration property for jbossHome was hard coded instead of a variable, so I had to edit it
      The link to OpenShift "quick start document" should be https://www.openshift.com/get-started
      The command "rhc-create-app -a tutorial -t jbossas-7.0" is out of date. I found this worked: "rhc create-app -a tutorial -t jbossas-7"
      I also found OpenShift now automatically attempts to clone the remote Git repository to the local workspace - unfortunately, I had port 22 blocked on the firewall, so it failed and I had to perform a recovery step.
      When I performed "git commit", the new war file in the deployments directory was ignored. I am new to Git, so I poked around with the Gui version of Git and I found the new file had to be staged before it could be commited.
      I used Android Development Tools Build: v21.0.1 and found some of the screen shots in the tutorial did not match mine - notably, the step for adding an existing project was different.
      The project name came up as "LibraryListActivity" after adding it, not "javaee-tutorial-jaxrs-andriod".
      When I went to add the external libraries, I found it more work tracking them down because I was not given the package names.
      I also did not find jackson-xc-1.6.3.jar in my m2 repository and had to download it separately.
      When I ran the Android simulator, it crashed. I found I had to go back and tick the "export" box for every jar in the "Order and Export" tab.

       

      It all worked in the end, but it was scary as I felt a show-stopper could spring up at any step!