0 Replies Latest reply on Jun 10, 2013 7:42 AM by Petr Mensik

    Debugging with VisualVM on JBoss 7.2

    Petr Mensik Newbie

      Hello,

       

      I would like to debug my application's behaviour with VisualVM. So I tried to follow this thread - https://community.jboss.org/thread/196428 - and it really works for JBoss 7.1.x. However, there were some changes in modules, now the AS is using some kind of layers. I changed the script in order to make it work with new 7.2 but it seems there is one module missing - org/jboss/remoting3. So the relevant part of the working script for 7.1.x looks like this

       

      MODULES="org/jboss/remoting3/remoting-jmx org/jboss/remoting3 org/jboss/logging org/jboss/xnio org/jboss/xnio/nio org/jboss/sasl org/jboss/marshalling org/jboss/marshalling/river"

       

      for MODULE in $MODULES

      do

      for JAR in `cd "$JBOSS_MODULEPATH/$MODULE/main/" && ls -1 *.jar`

          do

      CLASSPATH="$CLASSPATH:$JBOSS_MODULEPATH/$MODULE/main/$JAR"

          done

      done

       

      and this is what I've changed

       

      MODULES="org/jboss/remoting3/main org/jboss/logging/main org/jboss/xnio/main org/jboss/xnio/nio/main org/jboss/sasl/main org/jboss/marshalling/main org/jboss/marshalling/river/main"

       

      for MODULE in $MODULES

      do

      for JAR in `cd "$JBOSS_MODULEPATH/system/layers/base/$MODULE/" && ls -1 *.jar`

          do

      CLASSPATH="$CLASSPATH:$JBOSS_MODULEPATH/$MODULE/main/$JAR"

          done

      done

       

      but I am still not able make this work, if I connect to running JBoss instance (locally) through JMX, then I can't perform GC and inspect objects in the memory. So any thoughts how to make this work?