2 Replies Latest reply on Jun 11, 2013 10:07 AM by sd_23

    jboss 7.1 resource adapter problem

    sd_23 Newbie

      Hi. I have a problem deploying my resource adapter which is inside an ear.

      The structure of the ear file is the following:

      ear.PNG

      When i deploy the ear, i get this error message:

       

      JBAS014775:New missing/unsatisfied dependencies:
        service jboss.ra."connector" (missing) dependents: [service jboss.deployment.subunit."myEar.ear"."service-remote.jar".component.myMDB.CREATE]

       

      myMDB has an annotation @ResourceAdapter(value = "connector.rar") referring to my resource adapter, but the resource adapter isn't loaded yet. How can i say to jboss that i want to deploy connector.rar first and than the rest of the ear?

      By the way, when i remove the connector.rar from the ear and deploy it alone, it works perfectly. I only have this issue, when the rar is inside the ear.

        • 2. Re: jboss 7.1 resource adapter problem
          sd_23 Newbie

          Hello Jesper! I downloaded wildfly-8.0.0.Alpha1 and tried it. I get the same error:

           

          ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) JBAS014613: Operation ("deploy") failed - address: ([("deployment" => "myEar.ear")]) - failure description: {"JBAS014771: Services with missing/unavailable dependencies" => [

              "jboss.deployment.subunit.\"myEar.ear\".\"service-remote.jar\".component.myMDB.CREATE is missing [jboss.ra.\"myEar.ear#connector\"]"   

          ]}

          INFO  [org.jboss.as.server] (ServerService Thread Pool -- 30) JBAS018559: Deployed "myEar.ear" (runtime-name : "myEar.ear")

          INFO  [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report

          JBAS014775:    New missing/unsatisfied dependencies:

                service jboss.ra."myEar.ear#connector" (missing) dependents: [service jboss.deployment.subunit."myEar.ear"."service-remote.jar".component.myMDB.CREATE]