1 Reply Latest reply on Jun 18, 2013 4:08 AM by caraldel

    Problem deploying .war inside an .ear

    caraldel Newbie

      Hi !

       

      I'm trying to deploy into a JBoss 7.1 an application that contains one .jar with the EJB part and another .war with yhe web part. When I deploy it i have this warning and then the remote objects are not created.

       

      ADVERTENCIA [javax.enterprise.resource.webcontainer.jsf.config] (MSC service thread 1-6) javax.naming.NamingException: JBAS011843: Failed instantiate InitialContextFactory org.jboss.naming.remote.client.InitialContextFactory from classloader ModuleClassLoader for Module "deployment.MyAppEar-1.3.0.ear.MyAppWeb-1.3.0.war:main" from Service Module Loader: javax.naming.NamingException: JBAS011843: Failed instantiate InitialContextFactory org.jboss.naming.remote.client.InitialContextFactory from classloader ModuleClassLoader for Module "deployment.MyApp.ear.MyAppWeb-1.3.0.war:main" from Service Module Loader       

                at org.jboss.as.naming.InitialContextFactoryBuilder.createInitialContextFactory(InitialContextFactoryBuilder.java:64)

              at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:664) [rt.jar:1.6.0_20]

              at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:288) [rt.jar:1.6.0_20]

              at javax.naming.InitialContext.init(InitialContext.java:223) [rt.jar:1.6.0_20]

              at javax.naming.InitialContext.<init>(InitialContext.java:175) [rt.jar:1.6.0_20]

              at com.sun.faces.config.WebConfiguration.processJndiEntries(WebConfiguration.java:687) [jsf-impl-2.1.7-jbossorg-2.jar:]

              at com.sun.faces.config.WebConfiguration.<init>(WebConfiguration.java:134) [jsf-impl-2.1.7-jbossorg-2.jar:]

              at com.sun.faces.config.WebConfiguration.getInstance(WebConfiguration.java:194) [jsf-impl-2.1.7-jbossorg-2.jar:]

              at com.sun.faces.config.ConfigureListener.contextInitialized(ConfigureListener.java:163) [jsf-impl-2.1.7-jbossorg-2.jar:]

              at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3392) [jbossweb-7.0.13.Final.jar:]

              at org.apache.catalina.core.StandardContext.start(StandardContext.java:3850) [jbossweb-7.0.13.Final.jar:]

              at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:90) [jboss-as-web-7.1.1.Final.jar:7.1.1.Final]

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)

              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)

              at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_20]

              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_20]

              at java.lang.Thread.run(Thread.java:619) [rt.jar:1.6.0_20]

       

      I don't have any properties file, because they are in the same EAR. I try to acces from WEB part to EJB to use the Bean's methods.

      What's wrong ?

      Thanks!!