6 Replies Latest reply on Jun 18, 2013 10:08 AM by Norbert Winkler

    JBoss ActiveMQ integration, failed to deploy resource adapter

    Norbert Winkler Newbie

      I want to integrate ActiveMQ into the JBoss AS 7.1.1.

      I looked already at quite a number of threads on how to achieve this, but unfortunately I couldn't get it to work yet.

       

      Here is what I've done so far:

      - Downloaded activemq-rar-5.7.0.rar and put it in standalone/deployments

      - Adapted my standalone.xml (attached)

       

      Note the section:

      <subsystem xmlns="urn:jboss:domain:resource-adapters:1.0">

                  <resource-adapters>

                      <resource-adapter>

                          <archive>

                              activemq-rar-5.7.0.rar

                          </archive>

                          <transaction-support>XATransaction</transaction-support>

                          <config-property name="UseInboundSession">

                              false

                          </config-property>

                          <config-property name="Password">

                              admin123

                          </config-property>

                          <config-property name="UserName">

                              admin

                          </config-property>

                          <config-property name="ServerUrl">

                              vm://localhost?brokerConfig=xbean:broker-config.xml

                          </config-property>

                          <connection-definitions>

                              <connection-definition class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory" enabled="true" use-java-context="true" pool-name="ConnectionFactory"/>

                          </connection-definitions>

                          <admin-objects>

                              <admin-object class-name="org.apache.activemq.command.ActiveMQQueue" jndi-name="java:activemq/queue/FhBayQueue" use-java-context="true" pool-name="FhBayQueue">

                                  <config-property name="PhysicalName">

                                      FhBayQueue

                                  </config-property>

                              </admin-object>

                          </admin-objects>

                      </resource-adapter>

                  </resource-adapters>

              </subsystem>

       

      and

       

      <subsystem xmlns="urn:jboss:domain:ejb3:1.2">

                  <mdb>

                      <resource-adapter-ref resource-adapter-name="activemq-rar-5.7.0.rar"/>

                      <bean-instance-pool-ref pool-name="mdb-strict-max-pool"/>

                  </mdb>

      </subsystem>

       

      for integrating ActiveMQ.

       

      My problem is, that at startup of JBoss the deployment fails.

      Here is the stacktrace:

       

      05:07:50,875 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC00001: Failed to start service jboss.ra.deployment."activemq-rar-5.7.0.rar_1": org.jboss.msc.service.StartException in service jboss.ra.deployment."activemq-rar-5.7.0.rar_1": org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [activemq-rar-5.7.0]

                at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:127)

                at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_03]

                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_03]

                at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_03]

      Caused by: org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [activemq-rar-5.7.0]

                at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:111)

                ... 5 more

      Caused by: org.jboss.jca.deployers.common.DeployException: IJ020056: Deployment failed: file:/C:/public/SVE21/bin/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempd7e8ea44d91477bd/activemq-rar-5.7.0.rar-142d4e40baaa734/contents/

                at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:2186)

                at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService$AS7RaXmlDeployer.doDeploy(ResourceAdapterXmlDeploymentService.java:178)

                at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:104)

                ... 5 more

      Caused by: java.lang.NullPointerException

                at org.jboss.as.connector.metadata.deployment.AbstractResourceAdapterDeploymentService$AbstractAS7RaDeployer.buildJndiName(AbstractResourceAdapterDeploymentService.java:478)

                at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:1953)

                ... 7 more

       

      I would really appreciate any help.

        • 1. Re: JBoss ActiveMQ integration, failed to deploy resource adapter
          jaikiran pai Master

          Welcome to the forums!

           

           

          Norbert Winkler wrote:

           

          Caused by: java.lang.NullPointerException

                    at org.jboss.as.connector.metadata.deployment.AbstractResourceAdapterDeploymentService$AbstractAS7RaDeployer.buildJndiName(AbstractResourceAdapterDeploymentService.java:478)

                    at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:1953)

                    ... 7 more

           

          Please try the latest released version http://wildfly.org/download/ or the nightly build https://community.jboss.org/thread/224262 to see if that NullPointerException has been fixed.

           

          If it still fails on those newer versions, please post the new exception stacktraces.

          • 2. Re: JBoss ActiveMQ integration, failed to deploy resource adapter
            Norbert Winkler Newbie

            Thank you jaikiran.

            I tried the latest version.

             

            Unfortunately the error stays the same:

             

            12:29:38,184 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-7) MSC00001: Failed to start service jboss.ra.deployment."activemq-rar-5.7.0.rar_1": org.jboss.msc.service.StartException in service jboss.ra.deployment."activemq-rar-5.7.0.rar_1": org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [activemq-rar-5.7.0]

                      at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:127)

                      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_03]

                      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_03]

                      at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_03]

            Caused by: org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [activemq-rar-5.7.0]

                      at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:111)

                      ... 5 more

            Caused by: org.jboss.jca.deployers.common.DeployException: IJ020056: Deployment failed: file:/C:/public/SVE21/bin/jboss-as-7.1.1.Final/standalone/tmp/vfs/temp434ca8ce47c5e8f1/activemq-rar-5.7.0.rar-9faa510864e1180a/contents/

                      at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:2186)

                      at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService$AS7RaXmlDeployer.doDeploy(ResourceAdapterXmlDeploymentService.java:178)

                      at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:104)

                      ... 5 more

            Caused by: java.lang.NullPointerException

                      at org.jboss.as.connector.metadata.deployment.AbstractResourceAdapterDeploymentService$AbstractAS7RaDeployer.buildJndiName(AbstractResourceAdapterDeploymentService.java:478)

                      at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:1953)

                      ... 7 more

             

            I believe it might be a configuration issue, but I can't figure out what's wrong...

            • 3. Re: JBoss ActiveMQ integration, failed to deploy resource adapter
              Jesper Pedersen Master

              <connection-definiton ... jndi-name="java:/eis/blah" ...>

              1 of 1 people found this helpful
              • 4. Re: JBoss ActiveMQ integration, failed to deploy resource adapter
                Norbert Winkler Newbie

                Thank you Jesper,

                your answer helped me a little along the way.

                 

                I changed the connection-definition to the following:

                 

                <connection-definition jndi-name="java:jboss/activemq/QueueConnectionFactory"

                                                                                                                                 class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory"

                                                                                                                                 enabled="true"

                                                                                                                                 use-java-context="true"

                                                                                                                                 pool-name="ConnectionFactory" />

                 

                Now I'm getting a different kind of error.

                Sorry if I annoy you, but I'm kind of new to JBoss and quite lost in the configuration.

                Any idea what to do?

                 

                14:41:13,734 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.ra.deployment."activemq-rar-5.7.0.rar_1": org.jboss.msc.service.StartException in service jboss.ra.deployment."activemq-rar-5.7.0.rar_1": org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [activemq-rar-5.7.0]

                          at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:127)

                          at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                          at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_03]

                          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_03]

                          at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_03]

                Caused by: org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [activemq-rar-5.7.0]

                          at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:111)

                          ... 5 more

                Caused by: org.jboss.jca.deployers.common.DeployException: IJ020056: Deployment failed: file:/C:/public/SVE21/bin/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempdc24ecc459873840/activemq-rar-5.7.0.rar-901ad780275a3b9d/contents/

                          at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:2186)

                          at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService$AS7RaXmlDeployer.doDeploy(ResourceAdapterXmlDeploymentService.java:178)

                          at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:104)

                          ... 5 more

                Caused by: org.jboss.msc.service.DuplicateServiceException: Service jboss.connector.connection-factory.java:jboss/activemq/QueueConnectionFactory is already registered

                          at org.jboss.msc.service.ServiceRegistrationImpl.setInstance(ServiceRegistrationImpl.java:154) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                          at org.jboss.msc.service.ServiceControllerImpl.startInstallation(ServiceControllerImpl.java:227) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                          at org.jboss.msc.service.ServiceContainerImpl.install(ServiceContainerImpl.java:560) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                          at org.jboss.msc.service.ServiceTargetImpl.install(ServiceTargetImpl.java:201) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                          at org.jboss.msc.service.ServiceControllerImpl$ChildServiceTarget.install(ServiceControllerImpl.java:2228) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                          at org.jboss.msc.service.ServiceBuilderImpl.install(ServiceBuilderImpl.java:307) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                          at org.jboss.as.connector.metadata.deployment.AbstractResourceAdapterDeploymentService$AbstractAS7RaDeployer.bindConnectionFactory(AbstractResourceAdapterDeploymentService.java:269)

                          at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:1956)

                          ... 7 more

                • 5. Re: JBoss ActiveMQ integration, failed to deploy resource adapter
                  Jesper Pedersen Master

                  Start by running http://www.ironjacamar.org/doc/userguide/1.1/en-US/html/ch10.html#tools_rarinfo fron IronJacamar 1.1.0.Beta5 on the .rar -- then change the sample configuration to your setup, and paste it into standalone.xml.

                   

                  Then make sure that there are no duplicates with other queue names - like the one above.

                  1 of 1 people found this helpful
                  • 6. Re: JBoss ActiveMQ integration, failed to deploy resource adapter
                    Norbert Winkler Newbie

                    I'm feeling kind of dumb now, but it still is not working.

                     

                    My resource adapter looks like this now (copied from the rar-info output):

                     

                    <resource-adapters>

                                                            <resource-adapter>

                                                            <archive>activemq-rar-5.7.0.rar</archive>

                                                            <config-property name="UseInboundSession">false</config-property>

                                                            <config-property name="UserName">defaultUser</config-property>

                                                            <config-property name="ServerUrl">tcp://localhost:61616</config-property>

                                                            <config-property name="BrokerXmlConfig"/>

                                                            <config-property name="Clientid"/>

                                                            <config-property name="Password">defaultPassword</config-property>

                                                            <transaction-support>XATransaction</transaction-support>

                                                            <connection-definitions>

                                                              <connection-definition class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory" enabled="true" jndi-name="java:jboss/activemq/Connection" pool-name="Connection" use-ccm="true" use-java-context="true">

                                                                      <xa-pool>

                                                                        <min-pool-size>0</min-pool-size>

                                                                        <max-pool-size>10</max-pool-size>

                                                                        <prefill>false</prefill>

                                                                        <use-strict-min>false</use-strict-min>

                                                                        <flush-strategy>FailingConnectionOnly</flush-strategy>

                                                                        <pad-xid>false</pad-xid>

                                                                        <wrap-xa-resource>true</wrap-xa-resource>

                                                                      </xa-pool>

                                                                      <security>

                                                                        <application/>

                                                                      </security>

                                                                      <recovery no-recovery="false">

                                                                        <recover-credential>

                                                                                <user-name>user</user-name>

                                                                                <password>password</password>

                                                                        </recover-credential>

                                                                      </recovery>

                                                              </connection-definition>

                                                              <connection-definition class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory" enabled="true" jndi-name="java:jboss/activemq/QueueConnection" pool-name="QueueConnection" use-ccm="true" use-java-context="true">

                                                                      <xa-pool>

                                                                        <min-pool-size>0</min-pool-size>

                                                                        <max-pool-size>10</max-pool-size>

                                                                        <prefill>false</prefill>

                                                                        <use-strict-min>false</use-strict-min>

                                                                        <flush-strategy>FailingConnectionOnly</flush-strategy>

                                                                        <pad-xid>false</pad-xid>

                                                                        <wrap-xa-resource>true</wrap-xa-resource>

                                                                      </xa-pool>

                                                                      <security>

                                                                        <application/>

                                                                      </security>

                                                                      <recovery no-recovery="false">

                                                                        <recover-credential>

                                                                                <user-name>user</user-name>

                                                                                <password>password</password>

                                                                        </recover-credential>

                                                                      </recovery>

                                                              </connection-definition>

                                                            </connection-definitions>

                                                            <admin-objects>

                                                              <admin-object class-name="org.apache.activemq.command.ActiveMQQueue" enabled="true" jndi-name="java:jboss/activemq/queue/FhBayQueue" pool-name="FhBayQueue" use-java-context="true">

                                                                      <config-property name="FhBayQueue"/>

                                                              </admin-object>

                                                            </admin-objects>

                                                  </resource-adapter>

                     

                     

                     

                     

                    These are the errors I get with the new configuration:

                     

                    15:58:35,754 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-7) MSC00001: Failed to start service jboss.ra.deployment."activemq-rar-5.7.0.rar_1": org.jboss.msc.service.StartException in service jboss.ra.deployment."activemq-rar-5.7.0.rar_1": org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [activemq-rar-5.7.0]

                              at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:127)

                              at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                              at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                              at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_03]

                              at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_03]

                              at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_03]

                    Caused by: org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [activemq-rar-5.7.0]

                              at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:111)

                              ... 5 more

                    Caused by: org.jboss.jca.deployers.common.DeployException: IJ020056: Deployment failed: file:/C:/public/SVE21/bin/jboss-as-7.1.1.Final/standalone/tmp/vfs/tempfd68e1139ee3229f/activemq-rar-5.7.0.rar-95d74c8bd753d606/contents/

                              at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:2186)

                              at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService$AS7RaXmlDeployer.doDeploy(ResourceAdapterXmlDeploymentService.java:178)

                              at org.jboss.as.connector.metadata.deployment.ResourceAdapterXmlDeploymentService.start(ResourceAdapterXmlDeploymentService.java:104)

                              ... 5 more

                    Caused by: org.jboss.msc.service.DuplicateServiceException: Service jboss.connector.connection-factory.java:jboss/activemq/QueueConnection is already registered

                              at org.jboss.msc.service.ServiceRegistrationImpl.setInstance(ServiceRegistrationImpl.java:154) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                              at org.jboss.msc.service.ServiceControllerImpl.startInstallation(ServiceControllerImpl.java:227) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                              at org.jboss.msc.service.ServiceContainerImpl.install(ServiceContainerImpl.java:560) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                              at org.jboss.msc.service.ServiceTargetImpl.install(ServiceTargetImpl.java:201) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                              at org.jboss.msc.service.ServiceControllerImpl$ChildServiceTarget.install(ServiceControllerImpl.java:2228) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                              at org.jboss.msc.service.ServiceBuilderImpl.install(ServiceBuilderImpl.java:307) [jboss-msc-1.0.2.GA.jar:1.0.2.GA]

                              at org.jboss.as.connector.metadata.deployment.AbstractResourceAdapterDeploymentService$AbstractAS7RaDeployer.bindConnectionFactory(AbstractResourceAdapterDeploymentService.java:269)

                              at org.jboss.jca.deployers.common.AbstractResourceAdapterDeployer.createObjectsAndInjectValue(AbstractResourceAdapterDeployer.java:1956)

                              ... 7 more

                     

                     

                    15:58:35,772 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS015870: Deploy of deployment "activemq-rar-5.7.0.rar" was rolled back with failure message {"JBAS014671: Failed services" => {"jboss.ra.deployment.\"activemq-rar-5.7.0.rar_1\"" => "org.jboss.msc.service.StartException in service jboss.ra.deployment.\"activemq-rar-5.7.0.rar_1\": org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [activemq-rar-5.7.0]"}}

                    15:58:35,915 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-8) JBAS015877: Stopped deployment activemq-rar-5.7.0.rar in 142ms

                    15:58:35,917 INFO  [org.jboss.as.controller] (DeploymentScanner-threads - 2) JBAS014774: Service status report

                    JBAS014777:   Services which failed to start:      service jboss.ra.deployment."activemq-rar-5.7.0.rar_1": org.jboss.msc.service.StartException in service jboss.ra.deployment."activemq-rar-5.7.0.rar_1": org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [activemq-rar-5.7.0]

                     

                     

                    15:58:35,920 ERROR [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.ra.deployment.\"activemq-rar-5.7.0.rar_1\"" => "org.jboss.msc.service.StartException in service jboss.ra.deployment.\"activemq-rar-5.7.0.rar_1\": org.jboss.msc.service.StartException in anonymous service: JBAS010446: Failed to start RA deployment [activemq-rar-5.7.0]"}}}}

                    15:58:42,431 ERROR [stderr] (Periodic Recovery) Exception in thread "Periodic Recovery" java.lang.NoClassDefFoundError: org/apache/activemq/ra/ActiveMQManagedConnection

                     

                     

                    15:58:42,432 ERROR [stderr] (Periodic Recovery)           at org.apache.activemq.ra.ActiveMQManagedConnectionFactory.createManagedConnection(ActiveMQManagedConnectionFactory.java:188)

                     

                     

                    15:58:42,432 ERROR [stderr] (Periodic Recovery)           at org.jboss.jca.core.tx.jbossts.XAResourceRecoveryImpl.open(XAResourceRecoveryImpl.java:329)

                     

                     

                    15:58:42,433 ERROR [stderr] (Periodic Recovery)           at org.jboss.jca.core.tx.jbossts.XAResourceRecoveryImpl.getXAResources(XAResourceRecoveryImpl.java:157)

                     

                     

                    15:58:42,433 ERROR [stderr] (Periodic Recovery)           at com.arjuna.ats.internal.jbossatx.jta.XAResourceRecoveryHelperWrapper.getXAResources(XAResourceRecoveryHelperWrapper.java:52)

                     

                     

                    15:58:42,434 ERROR [stderr] (Periodic Recovery)           at com.arjuna.ats.internal.jta.recovery.arjunacore.XARecoveryModule.resourceInitiatedRecoveryForRecoveryHelpers(XARecoveryModule.java:462)

                     

                     

                    15:58:42,434 ERROR [stderr] (Periodic Recovery)           at com.arjuna.ats.internal.jta.recovery.arjunacore.XARecoveryModule.bottomUpRecovery(XARecoveryModule.java:385)

                     

                     

                    15:58:42,434 ERROR [stderr] (Periodic Recovery)           at com.arjuna.ats.internal.jta.recovery.arjunacore.XARecoveryModule.periodicWorkSecondPass(XARecoveryModule.java:166)

                     

                     

                    15:58:42,435 ERROR [stderr] (Periodic Recovery)           at com.arjuna.ats.internal.arjuna.recovery.PeriodicRecovery.doWorkInternal(PeriodicRecovery.java:789)

                     

                     

                    15:58:42,435 ERROR [stderr] (Periodic Recovery)           at com.arjuna.ats.internal.arjuna.recovery.PeriodicRecovery.run(PeriodicRecovery.java:371)

                     

                     

                    15:58:42,436 ERROR [stderr] (Periodic Recovery) Caused by: java.lang.ClassNotFoundException: org.apache.activemq.ra.ActiveMQManagedConnection from [Module "deployment.activemq-rar-5.7.0.rar:main" from Service Module Loader]

                     

                     

                    15:58:42,436 ERROR [stderr] (Periodic Recovery)           at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:196)

                     

                     

                    15:58:42,437 ERROR [stderr] (Periodic Recovery)           at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:444)

                     

                     

                    15:58:42,437 ERROR [stderr] (Periodic Recovery)           at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:432)

                     

                     

                    15:58:42,438 ERROR [stderr] (Periodic Recovery)           at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:374)

                     

                     

                    15:58:42,438 ERROR [stderr] (Periodic Recovery)           at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:119)

                     

                     

                    15:58:42,438 ERROR [stderr] (Periodic Recovery)           ... 9 more