2 Replies Latest reply on Jun 19, 2013 10:40 AM by Michael Moser

    Conflicting dependency when trying to install SwitchYard tooling into JBoss developer Studio 6.0.0.

    Michael Moser Newbie

      Hi, I wanted to have a peek into SwitchYard v0.8 to see what we will be into probably later this year. To do so I followed essentially https://docs.jboss.org/author/display/SWITCHYARD/Getting+Started.

       

      Installing switchyard-as7-0.8.0.Final.zip went all fine and I was able to build and run the RemoteInvoker example successfully, so AS and the SwitchYard runtime seem to be up and kicking.

       

      Next step would be to install me the Eclipse tooling and here I failed:

       

      I first downloaded and also installed JBoss Developer Studio 6.0.0 Stand Alone Universal Binary (i.e. bdevstudio-product-universal-6.0.0.GA-v20121206-1855-B186.jar) successfully.

      The first step after that is to add the Switchyard Tooling to the picture.

       

      I decided to use the online update site instead of the switchyard-site-assembly .zip-file, so I added 3 more update sites as instructed:

      1. http://download.jboss.org/jbosstools/updates/stable/juno/soa-tooling/switchyard/
      2. http://download.eclipse.org/releases/juno/
      3. http://download.eclipse.org/bpmn2-modeler/updates/juno/0.2.6/

       

      and then selected [x] SwitchYard Tooling to be added.

       

      But at this point I get stuck with the error message:

       

      Cannot complete the install because of a conflicting dependency.

        Software being installed: SwitchYard BPM Support 0.8.0.v20130322-2030-H280-CI (org.switchyard.tools.bpmn2.feature.feature.group 0.8.0.v20130322-2030-H280-CI)

        Software being installed: SwitchYard Editor 0.7.0.v20130109-0353-H243-CI (org.switchyard.tools.editor.feature.feature.group 0.7.0.v20130109-0353-H243-CI)

        Only one of the following can be installed at once:

          SwitchYard Tools BPMN2 Editor Extensions 0.7.0.v20130109-0353-H243-CI (org.switchyard.tools.ui.bpmn2 0.7.0.v20130109-0353-H243-CI)

          SwitchYard Tools BPMN2 Support 0.8.0.v20130322-2030-H280-CI (org.switchyard.tools.ui.bpmn2 0.8.0.v20130322-2030-H280-CI)

        Cannot satisfy dependency:

          From: SwitchYard BPM Support 0.8.0.v20130322-2030-H280-CI (org.switchyard.tools.bpmn2.feature.feature.group 0.8.0.v20130322-2030-H280-CI)

          To: org.switchyard.tools.ui.bpmn2 [0.8.0.v20130322-2030-H280-CI]

        Cannot satisfy dependency:

          From: SwitchYard Editor 0.7.0.v20130109-0353-H243-CI (org.switchyard.tools.editor.feature.feature.group 0.7.0.v20130109-0353-H243-CI)

          To: org.switchyard.tools.ui.bpmn2 [0.7.0.v20130109-0353-H243-CI]

       

      How do I resolve this? Any suggestion?

       

      Cheers,

      Michael