5 Replies Latest reply on Jul 3, 2013 3:16 PM by Ricardo Martinelli Oliveira

    JBoss AS 7 - JMX

    Adriano Schmidt Master

      Oi pessoal..

       

      alguém já habilitou o JMX para se conectar remotamente no JBoss com ferramentas como o VisualVM?

       

      estou utilizando o domain mode, imagino que eu tenha que configurar alguma coisa no subsystem jmx no meu domain.xml, mas o que exatamente eu devo fazer lá?

       

      Att,

      Adriano Schmidt

        • 1. Re: JBoss AS 7 - JMX
          Ricardo Martinelli Oliveira Apprentice

          Adriano,

           

          Creio que não é habilitar algo no JBoss AS7, mas o problema em si é que a comunicação JMX dessa versão é via JBoss Remoting e não é 100% compatível com ferramentas JMX comuns. Você pode dar uma olhada no diretório bin do JBoss que deve ter um script jconsole.sh, sugiro que dê uma olhada e crie um script similar para executar o VisualVM nessa versão.

          1 of 1 people found this helpful
          • 2. Re: JBoss AS 7 - JMX
            Mauricio Magnani Jr Master

            Oi Adriano,

             

            Dá uma olhada nesse link aqui acredito que pode ajudar:  http://blog.akquinet.de/2012/11/01/connecting-visualvm-with-a-remote-jboss-as-7-eap6-jvm-process/

             

            Abs

            1 of 1 people found this helpful
            • 3. Re: JBoss AS 7 - JMX
              Adriano Schmidt Master

              Oi galera.. obrigado pelas dicas!

               

              Segui o tutorial que o Maurício falou.. mas estou tentando acessar o JBoss remotamente pelo VisualVM e recebo o erro:

              evvm.png

               

              Estou no windows e o .bat é o seguinte:

               

              @echo off

              rem -------------------------------------------------------------------------

              rem jconsole script for Windows

              rem -------------------------------------------------------------------------

              rem

              rem A script for running jconsole with the remoting-jmx libraries on the classpath.


              rem $Id$


              @if not "%ECHO%" == ""  echo %ECHO%

              @if "%OS%" == "Windows_NT" setlocal


              if "x%VISUALVM_HOME%" =="x" (

                  echo VISUALVM_HOME environment variable has not been set - please set and re-run!

                  goto :EOF

              )


              if "%OS%" == "Windows_NT" (

                set "DIRNAME=%~dp0%"

              ) else (

                set DIRNAME=.\

              )


              pushd %DIRNAME%..

              set "RESOLVED_JBOSS_HOME=%CD%"

              popd


              if "x%JBOSS_HOME%" == "x" (

                set "JBOSS_HOME=%RESOLVED_JBOSS_HOME%"

              )


              pushd "%JBOSS_HOME%"

              set "SANITIZED_JBOSS_HOME=%CD%"

              popd


              if "%RESOLVED_JBOSS_HOME%" NEQ "%SANITIZED_JBOSS_HOME%" (

                  echo WARNING JBOSS_HOME may be pointing to a different installation - unpredictable results may occur.

              )


              set DIRNAME=


              if "%OS%" == "Windows_NT" (

                set "PROGNAME=%~nx0%"

              ) else (

                set "PROGNAME=jdr.bat"

              )


              rem Setup JBoss specific properties

              if "x%JAVA_HOME%" == "x" ( 

                echo JAVA_HOME is not set. Unable to locate the jars needed to run jconsole.

                goto END

              )


              rem Find jboss-modules.jar, or we can't continue

              if exist "%JBOSS_HOME%\jboss-modules.jar" (

                  set "RUNJAR=%JBOSS_HOME%\jboss-modules.jar"

              ) else (

                echo Could not locate "%JBOSS_HOME%\jboss-modules.jar".

                echo Please check that you are in the bin directory when running this script.

                goto END

              )


              rem Set default module root paths

              if "x%JBOSS_MODULEPATH%" == "x" (

                set  "JBOSS_MODULEPATH=%JBOSS_HOME%\modules"

              )


              rem Setup The Classpath

              set CLASSPATH=



              call :SearchForJars %JBOSS_MODULEPATH%\org\jboss\remoting3\remoting-jmx\main

              call :SearchForJars %JBOSS_MODULEPATH%\org\jboss\remoting3\main

              call :SearchForJars %JBOSS_MODULEPATH%\org\jboss\logging\main

              call :SearchForJars %JBOSS_MODULEPATH%\org\jboss\xnio\main

              call :SearchForJars %JBOSS_MODULEPATH%\org\jboss\xnio\nio\main

              call :SearchForJars %JBOSS_MODULEPATH%\org\jboss\sasl\main

              call :SearchForJars %JBOSS_MODULEPATH%\org\jboss\marshalling\main

              call :SearchForJars %JBOSS_MODULEPATH%\org\jboss\marshalling\river\main

               

              "%VISUALVM_HOME%\bin\visualvm.exe" "-cp:a" "%CLASSPATH%"


              :END

              goto :EOF


              :SearchForJars

              pushd %1

              for %%j in (*.jar) do call :ClasspathAdd %1\%%j

              popd

              goto :EOF


              :ClasspathAdd

              SET CLASSPATH=%CLASSPATH%;%1


              :EOF

               

              Se puderem me ajudar agradeço!

              • 4. Re: JBoss AS 7 - JMX
                Ricardo Martinelli Oliveira Apprentice

                E usando jconsole.sh? o problema persiste?

                • 5. Re: JBoss AS 7 - JMX
                  Ricardo Martinelli Oliveira Apprentice

                  Fala Adriano,

                   

                  Conseguiu resolver esse problema?