2 Replies Latest reply on Jun 21, 2013 11:02 AM by bhavesh bhagat

    Possible bug with JBoss-cli.sh (Native Interface) authentication with LDAP-Connection ???

    bhavesh bhagat Newbie

      Hi All,

       

      I have configured "LDAP Authentication" (Using LDAP outbound connection), for both http and native interfaces. Now, when I try to login to jboss-cli using following command, it works just fine:

      [misadm@dctradjbs01 bin]$ ./jboss-cli.sh --connect --controller=dctradjbs01:9999

      Username: bbhagat

      Password:

      [domain@dctradjbs01:9999 /] exit

       

      [misadm@dctradjbs01 bin]$

       

      But, if I use following command, it does NOT work:

      [misadm@dctradjbs01 bin]$ ./jboss-cli.sh --connect --user=bbhagat,--controller=dctradjbs01:9999

      Password:

      org.jboss.as.cli.CliInitializationException: Failed to connect to the controller

              at org.jboss.as.cli.impl.CliLauncher.initCommandContext(CliLauncher.java:280)

              at org.jboss.as.cli.impl.CliLauncher.main(CliLauncher.java:258)

              at org.jboss.as.cli.CommandLineMain.main(CommandLineMain.java:34)

              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

              at java.lang.reflect.Method.invoke(Method.java:597)

              at org.jboss.modules.Module.run(Module.java:270)

              at org.jboss.modules.Main.main(Main.java:411)

      Caused by: org.jboss.as.cli.CommandLineException: Unable to authenticate against controller at localhost:9999

              at org.jboss.as.cli.impl.CommandContextImpl.tryConnection(CommandContextImpl.java:938)

              at org.jboss.as.cli.impl.CommandContextImpl.connectController(CommandContextImpl.java:790)

              at org.jboss.as.cli.impl.CommandContextImpl.connectController(CommandContextImpl.java:766)

              at org.jboss.as.cli.impl.CliLauncher.initCommandContext(CliLauncher.java:278)

              ... 8 more

      Caused by: javax.security.sasl.SaslException: Authentication failed: all available authentication mechanisms failed

              at org.jboss.remoting3.remote.ClientConnectionOpenListener$Capabilities.handleEvent(ClientConnectionOpenListener.java:344)

              at org.jboss.remoting3.remote.ClientConnectionOpenListener$Capabilities.handleEvent(ClientConnectionOpenListener.java:227)

              at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:72)

              at org.xnio.channels.TranslatingSuspendableChannel.handleReadable(TranslatingSuspendableChannel.java:189)

              at org.xnio.channels.TranslatingSuspendableChannel$1.handleEvent(TranslatingSuspendableChannel.java:103)

              at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:72)

              at org.xnio.channels.TranslatingSuspendableChannel.handleReadable(TranslatingSuspendableChannel.java:189)

              at org.xnio.ssl.JsseConnectedSslStreamChannel.handleReadable(JsseConnectedSslStreamChannel.java:180)

              at org.xnio.channels.TranslatingSuspendableChannel$1.handleEvent(TranslatingSuspendableChannel.java:103)

              at org.xnio.ChannelListeners.invokeChannelListener(ChannelListeners.java:72)

              at org.xnio.nio.NioHandle.run(NioHandle.java:90)

              at org.xnio.nio.WorkerThread.run(WorkerThread.java:187)

              at ...asynchronous invocation...(Unknown Source)

              at org.jboss.remoting3.EndpointImpl.doConnect(EndpointImpl.java:270)

              at org.jboss.remoting3.EndpointImpl.doConnect(EndpointImpl.java:251)

              at org.jboss.remoting3.EndpointImpl.connect(EndpointImpl.java:349)

              at org.jboss.remoting3.EndpointImpl.connect(EndpointImpl.java:337)

              at org.jboss.as.protocol.ProtocolConnectionUtils.connect(ProtocolConnectionUtils.java:80)

              at org.jboss.as.protocol.ProtocolConnectionUtils.connectSync(ProtocolConnectionUtils.java:99)

              at org.jboss.as.protocol.ProtocolConnectionManager$EstablishingConnection.connect(ProtocolConnectionManager.java:256)

              at org.jboss.as.protocol.ProtocolConnectionManager.connect(ProtocolConnectionManager.java:70)

              at org.jboss.as.protocol.mgmt.FutureManagementChannel$Establishing.getChannel(FutureManagementChannel.java:176)

              at org.jboss.as.cli.impl.CLIModelControllerClient.getOrCreateChannel(CLIModelControllerClient.java:155)

              at org.jboss.as.cli.impl.CLIModelControllerClient$2.getChannel(CLIModelControllerClient.java:117)

              at org.jboss.as.protocol.mgmt.ManagementChannelHandler.executeRequest(ManagementChannelHandler.java:115)

              at org.jboss.as.protocol.mgmt.ManagementChannelHandler.executeRequest(ManagementChannelHandler.java:90)

              at org.jboss.as.controller.client.impl.AbstractModelControllerClient.executeRequest(AbstractModelControllerClient.java:236)

              at org.jboss.as.controller.client.impl.AbstractModelControllerClient.execute(AbstractModelControllerClient.java:141)

              at org.jboss.as.controller.client.impl.AbstractModelControllerClient.executeForResult(AbstractModelControllerClient.java:127)

              at org.jboss.as.controller.client.impl.AbstractModelControllerClient.execute(AbstractModelControllerClient.java:71)

              at org.jboss.as.cli.impl.CommandContextImpl.tryConnection(CommandContextImpl.java:929)

              ... 11 more

      [misadm@dctradjbs01 bin]$

       

      Is this a known bug OR I am missing something?

       

      Any help would be greatly appreciated!!!