1 Reply Latest reply on Jul 2, 2013 11:04 AM by Randall Hauch

    Repository initialisation timeout

    SEBASTIEN MICHEA Newbie

      When trying to startup on a dev environment an application on jboss 7.1.1 with modeshape 3.1.1.Final in which i copied node and indexes form production server, i see this in the log

       

      11:31:17,621 INFO  [org.jboss.as.clustering.infinispan] (MSC service thread 1-8) JBAS010281: Started nbeportal cache from modeshape container

       

       

      then after 10 minutes :

       

      11:41:18,590 ERROR [org.modeshape.jcr.cache.RepositoryCache] (MSC service thread 1-8) Repository 'nbeportal' is still not fully initialized after 10 minutes. Aborting.

       

       

      I saw that it is produced by

       

      https://github.com/ModeShape/modeshape/blob/master/modeshape-jcr/src/main/java/org/modeshape/jcr/cache/RepositoryCache.java

       

      but dont understand why...

       

      PS: I started the server without trying to rebuild the indexes.

        • 1. Re: Repository initialisation timeout
          Randall Hauch Master

          That error message "Repository 'nbeportal' is still not fully initialized after 10 minutes" has nothing to do with indexing. "Initialization" refers toModeShape attempting to start up and initialize a brand-new repository; e.g., define all the namespaces, register the built-in node types, load initial content (if any), etc. For a local cache, there is no way this should take 10 minutes; it should take just a fraction of a second.

           

          I suspect that it has something to do with copying the Infinispan cache storage files. Those files should represent an already-initialized repository, which means that upon startup ModeShape shouldn't have to do any initialization. So perhaps those files were corrupt or incomplete?

           

          I'd suggest turning on debug logging for ModeShape (e.g., "org.modeshape" logging context) and Infinispan (e.g., "org.infinispan").