5 Replies Latest reply on Jul 24, 2013 4:49 AM by Thomas Nordmeyer

    Failing to connect to managed container

    Thomas Nordmeyer Newbie

      Hi,

      I am running Arquillian tests from within Jenkins unsing maven. OS is Red Hat Enterprise Linux Server release 6.4 (Santiago).

       

      I can see that Arquillian starts the JBoss 7.1.1 Final server in the console. After the start the log just waits until timeout (I waitet up to 10 mutes and don't expect the packaging of the test to be the bottleneck).

      Every test ends with the exception

      (...)

      Caused by: java.util.concurrent.TimeoutException: Managed server was not started within [30] s

      at org.jboss.as.arquillian.container.managed.ManagedDeployableContainer.startInternal(ManagedDeployableContainer.java:163)

      ... 68 more

       

      I tried many different arquillian.xml configurations and tried removing the realms from the management interfaces in jboss without getting the tests running.

       

      It would be very helpful, if Arquillian told me, how it tried to connect (host, port, authentication) and where it misses an answer.

       

      Is there a way to adjust Arquillians logging?

       

      CU,

      Thomas

       

      arquillian.xml

      <arquillian xmlns="http://jboss.org/schema/arquillian"

         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

         xsi:schemaLocation="http://jboss.org/schema/arquillian

              http://jboss.org/schema/arquillian/arquillian_1_0.xsd">

       

         <defaultProtocol type="Servlet 3.0" />

       

         <container qualifier="jboss" default="true">

            <configuration>

               <property name="jbossHome">/cfn365/jboss</property>

               <property name="startupTimeoutInSeconds">600</property>

            </configuration>

            <protocol type="Servlet 3.0">

              <property name="host">localhost</property>

              <property name="port">8080</property>

            </protocol>

         </container>

       

          <extension qualifier="suite">

              <property name="deploymentClass">com.claas.cfn365.backend.Deployments</property>

          </extension>

       

      </arquillian>

       

      profile from pom.xml

      <profile>

          <id>arq-jbossas-managed</id>

          <dependencies>

              <dependency>

                  <groupId>org.jboss.spec</groupId>

                  <artifactId>jboss-javaee-6.0</artifactId>

                  <version>1.0.0.Final</version>

                  <type>pom</type>

                  <scope>provided</scope>

              </dependency>

              <dependency>

                  <groupId>org.jboss.as</groupId>

                  <artifactId>jboss-as-arquillian-container-managed</artifactId>

                  <version>7.1.1.Final</version>

                  <scope>test</scope>

              </dependency>

          </dependencies>

      </profile>