3 Replies Latest reply on Jul 11, 2013 3:52 PM by Tomaz Cerar

    CLI script broken when upgrading from AS 7.1.1 to EAP 6.1.0

    Jim Johnson Newbie

      I have a CLI script that is used to provision a new JBoss instance.  Part of the script it to set up a security domain for our database using a custom login module.  The script syntax I am using is:

       

      /subsystem=security/security-domain=AppDSDomain:add(cache-type="default")

      /subsystem=security/security-domain=AppDSDomain/authentication=classic:add(login-modules=[{"code"=>"mypackage.MyLoginModule","flag"=>"required","module-options"=>[("principal"=>"principal"),("userName"=>"user"),("passwordKey"=>"pw_key")]}])

       

      This worked great in 7.1.1.  In 6.1.0 I get an error message:

       

      Operation 'add' does not expect any property.

       

      The only reference I found to this online was a WildFly bug report about it.

       

      https://issues.jboss.org/browse/WFLY-108

       

      Question:  Is there a work around for this in 6.1.0?  I tried a few different things to add a login-module to a security domain through the CLI but coudln't get anything to work.

       

      Thanks!

       

      Message was edited by: jaikiran pai - Edited subject from "CLI script broken when upgrading from AS 7.1.1 to AS 6.1.0" to "CLI script broken when upgrading from AS 7.1.1 to EAP 6.1.0"