1 Reply Latest reply on Nov 17, 2014 4:53 PM by M Muthukumaran

    Jboss 7.2 / EAP 6.1 and Apache integration

    Tomislav Mihaldinec Newbie

      Hi,

       

      On our productive systems which runs both Jboss 7.2 Alpha and EAP 6.1 we are facing problems that Apache ocasionally responds with 503 and than Apache disables worker for 1sek

       

      [Thu Jul 11 08:54:17.338458 2013] [proxy:error] [pid 23044:tid 140408162027264] (111)Connection refused: AH00957: HTTP: attempt to connect to 127.0.0.1:9081 (localhost) failed

       

      and than start to respons with 404 and error in error.log is:

      [Thu Jul 11 08:54:17.338499 2013] [proxy:error] [pid 23044:tid 140408162027264] AH00959: ap_proxy_connect_backend disabling worker for (localhost) for 1s

      [Thu Jul 11 08:54:17.338506 2013] [proxy_http:error] [pid 23044:tid 140408162027264] [client 10.243.166.100:58345] AH01114: HTTP: failed to make connection to backend: localhost, referer: http://www.xxxx.xxx/

       

      System:

      Linux RHEL 6.2

      Jboss 7.2 Alpha and Jboss EAP6.2

      Apache/2.4.3

       

      Apache config is plain mod_proxy

       

      KeepAliveTimeout 10

      MaxKeepAliveRequests 100

      KeepAlive On

      Timeout 120

      HostnameLookups Off

       

      <IfModule worker.c>

      ThreadLimit         25

      ServerLimit         64

      StartServers         1

      MaxClients         600

      MinSpareThreads     25

      MaxSpareThreads     75

      ThreadsPerChild     25

      MaxRequestsPerChild 400

      </IfModule>

       

        ProxyPass /APP-WebApps-Billing http://localhost:9081/APP-WebApps-Billing retry=1

        ProxyPassReverse /APP-WebApps-Billing http://localhost:9081/APP-WebApps-Billing

        ProxyPass /APP-WebApps-Authentication http://localhost:9081/APP-WebApps-Authentication retry=1

        ProxyPassReverse /APP-WebApps-Authentication http://localhost:9081/APP-WebApps-Authentication

        ProxyPassReverseCookiePath /APP-WebApps-Authentication /

       

      my assumption is that thread pool on Jboss is full and it cannot serve new request

       

      my question is..

      how to increase default http thread pool

       

      this is part of standalone.xml where i tried to add executor thread pool

      <subsystem xmlns="urn:jboss:domain:threads:1.0">

              <bounded-queue-thread-pool name="http-executor">

                      <core-threads count="40"/>

                      <queue-length count="40"/>

                      <max-threads count="40"/>

                      <keepalive-time time="10" unit="seconds" />

              </bounded-queue-thread-pool>

      </subsystem>

       

      <subsystem xmlns="urn:jboss:domain:web:1.4" default-virtual-server="default-host" native="false">

              <connector enable-lookups="false" enabled="true"

                      executor="http-executor"

                      max-connections="200"

                      max-post-size="2048" max-save-post-size="4096"

                      name="http" protocol="HTTP/1.1"

                      scheme="http" secure="false" socket-binding="http" />

      </connector>

       

      also, on second server with default standalone.xml problem is the same

       

      what im doing wrong?

       

      thanks

      tomislav