6 Replies Latest reply on Jul 11, 2013 9:56 PM by Willem Jiang

    Trouble while starting my local Fuse

    Ramzy Jelassi Newbie

      Hi all,

       

      i used to start my local Fuse ESB   without any trouble , but suddenly i am getting this exception :

       

      Please wait while Fuse ESB is loading...

      96% =====================================================================> 

      ERROR: Bundle org.apache.cxf.cxf-tools-java2ws 334 Error starting mvn:org.apach

      e.cxf/cxf-tools-java2ws/2.6.0.fuse-71-047 (org.osgi.framework.BundleException: U

      nresolved constraint in bundle org.apache.cxf.cxf-tools-java2ws 334: Unable to

      resolve 334.0: missing requirement http://334.0 osgi.wiring.package; (&(osgi.wiring.

      package=org.apache.cxf.tools.wsdlto.core)(version>=2.6.0)(!(version>=3.0.0))) [c

      aused by: Unable to resolve 336.0: missing requirement http://336.0 osgi.wiring.packa

      ge; (&(osgi.wiring.package=org.apache.cxf.tools.validator)(version>=2.6.0)(!(ver

      sion>=3.0.0)))])

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.c

      xf.cxf-tools-java2ws 334: Unable to resolve 334.0: missing requirement http://334.0

      osgi.wiring.package; (&(osgi.wiring.package=org.apache.cxf.tools.wsdlto.core)(v

      ersion>=2.6.0)(!(version>=3.0.0))) [caused by: Unable to resolve 336.0: missing

      requirement http://336.0 osgi.wiring.package; (&(osgi.wiring.package=org.apache.cxf.t

      ools.validator)(version>=2.6.0)(!(version>=3.0.0)))]

      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:405

      4)

      at org.apache.felix.framework.Felix.startBundle(Felix.java:1959)

      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1282)

       

      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart

      LevelImpl.java:298)

      at java.lang.Thread.run(Thread.java:662)

      ERROR: Bundle org.apache.cxf.cxf-tools-wsdlto-frontend-jaxws 335 Error startin

      g mvn:org.apache.cxf/cxf-tools-wsdlto-frontend-jaxws/2.6.0.fuse-71-047 (org.osgi

      .framework.BundleException: Unresolved constraint in bundle org.apache.cxf.cxf-t

      ools-wsdlto-frontend-jaxws 335: Unable to resolve 335.0: missing requirement [

      335.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.cxf.tools.validato

      r)(version>=2.6.0)(!(version>=3.0.0))))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.c

      xf.cxf-tools-wsdlto-frontend-jaxws 335: Unable to resolve 335.0: missing requi

      rement http://335.0 osgi.wiring.package; (&(osgi.wiring.package=org.apache.cxf.tools.

      validator)(version>=2.6.0)(!(version>=3.0.0)))

      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:405

      4)

      at org.apache.felix.framework.Felix.startBundle(Felix.java:1959)

      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1282)

       

      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart

      LevelImpl.java:298)

      at java.lang.Thread.run(Thread.java:662)

      ERROR: Bundle org.apache.cxf.cxf-tools-wsdlto-core 336 Error starting mvn:org.

      apache.cxf/cxf-tools-wsdlto-core/2.6.0.fuse-71-047 (org.osgi.framework.BundleExc

      eption: Unresolved constraint in bundle org.apache.cxf.cxf-tools-wsdlto-core [33

      6]: Unable to resolve 336.0: missing requirement http://336.0 osgi.wiring.package; (&

      (osgi.wiring.package=org.apache.cxf.tools.validator)(version>=2.6.0)(!(version>=

      3.0.0))))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.c

      xf.cxf-tools-wsdlto-core 336: Unable to resolve 336.0: missing requirement [33

      6.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.cxf.tools.validator)

      (version>=2.6.0)(!(version>=3.0.0)))

      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:405

      4)

      at org.apache.felix.framework.Felix.startBundle(Felix.java:1959)

      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1282)

       

      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart

      LevelImpl.java:298)

      at java.lang.Thread.run(Thread.java:662)

      ERROR: Bundle org.apache.cxf.cxf-tools-wsdlto-databinding-jaxb 337 Error start

      ing mvn:org.apache.cxf/cxf-tools-wsdlto-databinding-jaxb/2.6.0.fuse-71-047 (org.

      osgi.framework.BundleException: Unresolved constraint in bundle org.apache.cxf.c

      xf-tools-wsdlto-databinding-jaxb 337: Unable to resolve 337.0: missing require

      ment http://337.0 osgi.wiring.package; (&(osgi.wiring.package=org.apache.cxf.tools.ws

      dlto.core)(version>=2.6.0)(!(version>=3.0.0))) [caused by: Unable to resolve 336

      .0: missing requirement http://336.0 osgi.wiring.package; (&(osgi.wiring.package=org.

      apache.cxf.tools.validator)(version>=2.6.0)(!(version>=3.0.0)))])

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.c

      xf.cxf-tools-wsdlto-databinding-jaxb 337: Unable to resolve 337.0: missing req

      uirement http://337.0 osgi.wiring.package; (&(osgi.wiring.package=org.apache.cxf.tool

      s.wsdlto.core)(version>=2.6.0)(!(version>=3.0.0))) [caused by: Unable to resolve

      336.0: missing requirement http://336.0 osgi.wiring.package; (&(osgi.wiring.package=

      org.apache.cxf.tools.validator)(version>=2.6.0)(!(version>=3.0.0)))]

      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:405

      4)

      at org.apache.felix.framework.Felix.startBundle(Felix.java:1959)

      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1282)

       

      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart

      LevelImpl.java:298)

      at java.lang.Thread.run(Thread.java:662)

      ERROR: Bundle org.apache.cxf.cxf-tools-misctools 338 Error starting mvn:org.ap

      ache.cxf/cxf-tools-misctools/2.6.0.fuse-71-047 (org.osgi.framework.BundleExcepti

      on: Unresolved constraint in bundle org.apache.cxf.cxf-tools-misctools 338: Un

      able to resolve 338.0: missing requirement http://338.0 osgi.wiring.package; (&(osgi.

      wiring.package=org.apache.cxf.tools.validator.internal)(version>=2.6.0)(!(versio

      n>=3.0.0))))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.c

      xf.cxf-tools-misctools 338: Unable to resolve 338.0: missing requirement [338.

      0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.cxf.tools.validator.in

      ternal)(version>=2.6.0)(!(version>=3.0.0)))

      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:405

      4)

      at org.apache.felix.framework.Felix.startBundle(Felix.java:1959)

      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1282)

       

      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart

      LevelImpl.java:298)

      at java.lang.Thread.run(Thread.java:662)

      ERROR: Bundle org.apache.cxf.cxf-tools-wsdlto-frontend-javascript 339 Error st

      arting mvn:org.apache.cxf/cxf-tools-wsdlto-frontend-javascript/2.6.0.fuse-71-047

      (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache

      .cxf.cxf-tools-wsdlto-frontend-javascript 339: Unable to resolve 339.0: missin

      g requirement http://339.0 osgi.wiring.package; (&(osgi.wiring.package=org.apache.cxf

      .tools.validator)(version>=2.6.0)(!(version>=3.0.0))))

      org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.c

      xf.cxf-tools-wsdlto-frontend-javascript 339: Unable to resolve 339.0: missing

      requirement http://339.0 osgi.wiring.package; (&(osgi.wiring.package=org.apache.cxf.t

      ools.validator)(version>=2.6.0)(!(version>=3.0.0)))

      at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:405

      4)

      at org.apache.felix.framework.Felix.startBundle(Felix.java:1959)

      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1282)

       

      at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart

      LevelImpl.java:298)

      at java.lang.Thread.run(Thread.java:662)

      97% =====================================================================> 

       

      if i understood well the osgi.wiring.package is no longer available , i ignore really the reasons , how is it possible to fix this issu ?

       

      I tried to fix the problem by executing the folliwng command ;

      install -s mvn:org.apache.cxf/cxf-tools-common/2.6.0.fuse-71-047

       

      but , unfortunately it does not seem to fix the problem !

        • 1. Re: Trouble while starting my local Fuse
          Freeman(Yue) Fang Master

          Hi,

           

          You can use

           

          la

           

          to see if cxf-tools-common bundle really get started.

           

          or you can post the result of

          la

           

          also, you can use

           

          features:install cxf-tools

          to install all cxf tools related bundles.

           

          Freeman

          • 2. Re: Trouble while starting my local Fuse
            Ramzy Jelassi Newbie

            what do you mean by "la"  ? maybe you meant to post a command , i can not read it unfortunately !

             

            As for re-installing cxf tools with the suggested command i get the following exception:

             

             

            java.lang.RuntimeException: URL [mvn:org.fusesource.esb/fuse-esb/7.0.0.fuse-061/xml/features] could not be resolved.

                at org.ops4j.pax.url.mvn.internal.Connection.getInputStream(Connection.java:195)[1:org.ops4j.pax.url.mvn:1.3.5]

                at org.apache.karaf.features.internal.FeatureValidationUtil.validate(FeatureValidationUtil.java:47)[21:org.apache.karaf.features.core:2.3.0.fuse-71-047]

                at org.apache.karaf.features.internal.FeaturesServiceImpl.validateRepository(FeaturesServiceImpl.java:198)[21:org.apache.karaf.features.core:2.3.0.fuse-71-047]

                at org.apache.karaf.features.internal.FeaturesServiceImpl.internalAddRepository(FeaturesServiceImpl.java:239)[21:org.apache.karaf.features.core:2.3.0.fuse-71-047]

                at org.apache.karaf.features.internal.FeaturesServiceImpl.getFeatures(FeaturesServiceImpl.java:998)[21:org.apache.karaf.features.core:2.3.0.fuse-71-047]

                at org.apache.karaf.features.internal.FeaturesServiceImpl.getFeature(FeaturesServiceImpl.java:956)[21:org.apache.karaf.features.core:2.3.0.fuse-71-047]

                at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:378)[21:org.apache.karaf.features.core:2.3.0.fuse-71-047]

                at org.apache.karaf.features.command.InstallFeatureCommand.doExecute(InstallFeatureCommand.java:62)[25:org.apache.karaf.features.command:2.3.0.fuse-71-047]

                at org.apache.karaf.features.command.FeaturesCommandSupport.doExecute(FeaturesCommandSupport.java:41)[25:org.apache.karaf.features.command:2.3.0.fuse-71-047]

                at org.apache.karaf.shell.console.OsgiCommandSupport.execute(OsgiCommandSupport.java:38)[15:org.apache.karaf.shell.console:2.3.0.fuse-71-047]

                at org.apache.felix.gogo.commands.basic.AbstractCommand.execute(AbstractCommand.java:35)[15:org.apache.karaf.shell.console:2.3.0.fuse-71-047]

                at org.apache.felix.gogo.runtime.CommandProxy.execute(CommandProxy.java:78)[15:org.apache.karaf.shell.console:2.3.0.fuse-71-047]

                at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:474)[15:org.apache.karaf.shell.console:2.3.0.fuse-71-047]

                at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:400)[15:org.apache.karaf.shell.console:2.3.0.fuse-71-047]

                at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)[15:org.apache.karaf.shell.console:2.3.0.fuse-71-047]

                at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)[15:org.apache.karaf.shell.console:2.3.0.fuse-71-047]

                at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)[15:org.apache.karaf.shell.console:2.3.0.fuse-71-047]

                at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:89)[15:org.apache.karaf.shell.console:2.3.0.fuse-71-047]

                at org.apache.karaf.shell.console.jline.Console.run(Console.java:171)[15:org.apache.karaf.shell.console:2.3.0.fuse-71-047]

                at org.apache.karaf.shell.console.jline.DelayedStarted.run(DelayedStarted.java:61)[15:org.apache.karaf.shell.console:2.3.0.fuse-71-047]

            • 3. Re: Trouble while starting my local Fuse
              Freeman(Yue) Fang Master

              "la" is a command from the FUSE ESB console which can list all bundles status.

               

               

              Anyway, the exception here

               

              java.lang.RuntimeException: URL [mvn:org.fusesource.esb/fuse-esb/7.0.0.fuse-061/xml/features] could not be resolved.

                  at org.ops4j.pax.url.mvn.internal.Connection.getInputStream(Connection.java:195)[1:org.ops4j.pax.url.mvn:1.3.5]

                  at org.apache.karaf.features.internal.FeatureValidationUtil.validate(FeatureValidationUtil.java:47)[21:org.apache.karaf.features.core:2.3.0.fuse-71-047]

               

              is interesting, which means you try to use FUSE ESB 7.0.0 features file from 7.1 kit, and as I know 7.0.0.fuse-061 isn't an offical released version.

               

              Seems somehow your kit messed up, did you change any default configuration?

              • 4. Re: Trouble while starting my local Fuse
                Ramzy Jelassi Newbie

                no at all , i did not chaneg any feature or even the default configuration

                • 5. Re: Trouble while starting my local Fuse
                  Freeman(Yue) Fang Master

                  You mean you simple run

                   

                  features:install cxf-tools

                   

                  but you see that exception?

                   

                  I can't see any reason this command will try to download mvn:org.fusesource.esb/fuse-esb/7.0.0.fuse-061/xml/features,

                  I'm curious how is the mvn:org.fusesource.esb/fuse-esb/7.0.0.fuse-061/xml/features get introduced.

                   

                  and I just tried "features:install cxf-tools" on my FUSE ESB 7.1 kit, it works from my side.

                   

                  How about you post the result of

                   

                  features:listurl

                   

                  here?

                   

                  Also did you copy any data folder from other FUSE ESB version to FUSE ESB 7.1 kit?

                   

                   

                  • 6. Re: Trouble while starting my local Fuse
                    Willem Jiang Newbie

                    Please check  if you can access the file $FUSE_HOME/system/org/fusesource/esb/fuse-esb/7.0.1.fuse-070/fuse-esb-7.0.1.fuse-070-features.xml rightly.

                    Maybe you need to reinstall the fuse esb again.