1 Reply Latest reply on Jul 14, 2013 9:00 PM by lifeonatrip

    Issue JBWEB003043 in jboss:web once migrated from 7.1.1 to 7.2

    lifeonatrip Newbie

      Hi all,

       

      I recently migrated from a functional 7.1.1 to 7.2 in order to add  the SYSLOG appender functionality without building a custom handler.

       

      Once started the jboss:web subsystem gives me this error:

       

       

       

      09:50:07,523 ERROR [org.apache.coyote.http11] (MSC service thread 1-3) JBWEB003043: Error initializing endpoint: java.io.IOException: JBWEB002000: Alias name jboss does not identify a key entry

       

       

       

      Consequently, all the web-related configurations (connectors and such) are not working.

      Can someone help me on debugging this issue?  Looks like is an issue with the keystore aliases.

       

      I use standalone-full.xml (attached) and there is only 1 alias in the keystore: "mysite-services".

       

       

      Thanks.

        • 1. Re: Issue JBWEB003043 in jboss:web once migrated from 7.1.1 to 7.2
          lifeonatrip Newbie

          I found the solution:

           

          On the line

           

           

          <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https" secure="true" enable-lookups="false">

                <ssl name="ssl" password="changeit" certificate-key-file="${jboss.server.config.dir}/mysite-services.ks" protocol="TLSv1" verify-client="false"/>

          </connector>

           

          The name is equal to "ssl" but the alias inside the keystore is "mysite-services". Because of that you have to specify the alias name with key-alias="mysite-services" inside the <ssl> tag of your connector.

           

           

          <connector name="https" protocol="HTTP/1.1" scheme="https" socket-binding="https" secure="true" enable-lookups="false">

          <ssl name="ssl" password="changeit" certificate-key-file="${jboss.server.config.dir}/mysite-services.ks" protocol="TLSv1" verify-client="false" key-alias="mysite-services"/>

          </connector>

          With this, the problem seems solved.

           

          The question: why this happens only with Jboss 7.2 is still open anyway.