2 Replies Latest reply on Jul 16, 2013 4:42 AM by Maxim Dmitriev

    Stop at Eclipse breakpoints when running an applicaion on JBoss AS 7.1

    Maxim Dmitriev Newbie

      Hello. I read the guide on https://community.jboss.org/thread/177687 and made the following steps.

       

      1. I compiled and deployed my web project and deployed it on JBoss AS 7.1 by clicking Run on Server -> JBoss AS 7.1 in Eclipse.
      2. I stopped JBoss AS in Eclipse.
      3. I uncommented the line JAVA_OPTS="$JAVA_OPTS -Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n" in the $JBOSS_HOME/bin/standalone.conf file
      4. I executed $JBOSS_HOME/bin/standalone.sh
      5. I updated the page localhost:8080/MyProject/ in the browser and it worked
      6. I executed Debug -> Debug Configurations in Eclipse, then I created a new configuration with the localhost as the host, 8787 as the port, and MyProject as the project name.
      7. I pressed the Debug button.

       

      When I reach a breakpoint I added, nothing happens.

       

      I expected that Eclipse would stop at the breakpoint as it does in a simple Java application project. What did I do wrong?

       

      OS and Eclipse versions.

       

      Eclipse version: Indigo.

      Java.

      java version "1.6.0_43" Java(TM) SE Runtime Environment (build 1.6.0_43-b01) Java HotSpot(TM) 64-Bit Server VM (build 20.14-b01, mixed mode) 

       

      Edit #1.

      1. Window -> Preferences -> Java -> Installed JRE's
      2. Edit JRE being used
      3. Edit 'Default VM Arguments' line 

        -XX:+UseParallelGC

       

      It didn't help.