6 Replies Latest reply on Jul 16, 2013 3:00 PM by R J

    HornetQ client prog

    R J Newbie

      Hi All,

       

      We are using Jboss5 with hornetq 2.2.5. It worked well locally so we moved to development box . We have issues after moving into the DEV box . The messsgaes are not going to Q .

      Should we change the code also ?? We just changed the configuration .. All the queues are deployed .. please let me know and suggest.

       

      Thanks,

      RJ

        • 1. Re: HornetQ client prog
          Andy Taylor Master

          with such little informatuion its difficult for us to help you.

          • 2. Re: HornetQ client prog
            R J Newbie

            Thanks for the reply Andy .. I need one for suggestion from you .. I just checked I missed jndi configuration .

             

            <bean name="JNDIServer" class="org.jnp.server.Main">

                <property name="namingInfo">

                    <inject bean="Naming"/>

                </property>

                <property name="port">1099</property>

                <property name="bindAddress">localhost</property>

                <property name="rmiPort">1098</property>

                <property name="rmiBindAddress">localhost</property>

            </bean>                       

             

            But when I start the server I am getting 1099 port is already in use. Can I use any other number or is it must to pass port number for EVERY NODE .

             

            my jndi.propertis:

             

            java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory

            java.naming.factory.url.pkgs=org.jboss.naming:org.jnp.interfaces  

            under /Javahome/server/node00/conf/

             

            Thanks,

            RJ

            • 3. Re: HornetQ client prog
              Andy Taylor Master

              But when I start the server I am getting 1099 port is already in use. Can I use any other number or is it must to pass port number for EVERY NODE .

              that just means another process is using that port, you should just change the port you want or stop the other process using the same port number

              1 of 1 people found this helpful
              • 4. Re: HornetQ client prog
                R J Newbie

                Andy,

                 

                One last question ..

                 

                I am able to to send the message .. I am seeing in the LOGs .. But not receiving the message ..

                Should the Debug the code or is there any better way to activate the listener (make the listener up -- if it is default in hornertq)

                 

                Thanks,

                RJ

                • 5. Re: HornetQ client prog
                  Andy Taylor Master

                  I have no way of knowing, you havent really told me anything apart ffrom 'it doesnt work'

                  • 6. Re: HornetQ client prog
                    R J Newbie

                    Andy,

                     

                    The Issue is solved .. It was MDB .. we kept hornet-ra.rar. where as it was referring to jms-ra.rar from the code . We renamed and changed some config files .

                    Its working!!

                     

                    Thanks,

                    RJ