2 Replies Latest reply on Jul 19, 2013 11:59 AM by Dan Florian

    Unable To Start Agent Because Of Registration/Authentication Issue

    Dan Florian Newbie

      Environment: OS X, EAP 6.1.0.Beta, Agent 4.7, RHQ server 4.7

       

      I am unable to start the RHQ agent (see attached logs). I was running agent and server fine before. Not sure what happened. I did try and run on a different wifi (didn't work). Then back to original wifi and still wouldn't work. But not sure that would matter (?).

       

      I have tried --clean, --cleanconfig, -Drhq.agent.security-token=<value from RHQ web console> when starting the agent but no luck.

       

      I have reinstalled both the RHQ server and agent (downloaded from server) also to try and fix this. I am still using the same Postgres DB I used before the reinstalls (is that a problem?).

       

      I am using "localhost" as name and all hostname/IP values during agent setup/clean whilst leaving all the default port values.

       

      I installed the RHQ server after modifying a few properties (autoinstall.enabled, server.database.connection-url, database.server) in rhq-server.properties (attached). I then started the server and in another console ran the installer.

       

      In the RHQ Web Console "localhost" has an error icon with this message: Failed to logout. Root cause: from SubjectGWTService_Proxy.logout.

       

      Thanks for any help!

        • 1. Re: Unable To Start Agent Because Of Registration/Authentication Issue
          jay shaughnessy Expert

          Looking at TopologyServers.png it seem that your server IP keeps changing while the DB stays the same.  This IP's look like they are from your personal LAN, so if you've been restarting your router or something then that can happen.

           

          Delete the DOWN entries.

           

          You want to make sure the IP stays the same.  If in fact you are just trying to run a local agent, you can edit the NORMAL server entry to have an endpoint of 127.0.0.1 or localhost.  If you want to run remote agents then you'll want an IP or alias that doesn't change.   Your agent can't connect to the server because it is trying to use one of the dated endpoint addresses, which it received when it previously connected to the server.  Starting with --setup should allow you to get past that by re-establishing the connection info.  Make sure that the agent name *stays the same* when you use --setup.

           

          A second possible issue is that "daniels-laptop", which is your public server endpoint, at the the moment, is not a resolvable alieas by the agent.  if not then it will not be able to connect.  From the agent box try a 'ping daniels-laptop' and see if that works.

          • 2. Re: Unable To Start Agent Because Of Registration/Authentication Issue
            Dan Florian Newbie

            Now just have the one NORMAL entry on Servers page. I changed that entry to have an endpoint of "localhost." The agent is also running locally and "ping daniels-laptop" is successful from a terminal. I ran the agent with the "--setup" option. Still getting same errors.