3 Replies Latest reply on Jul 26, 2013 3:23 AM by Freeman(Yue) Fang

    Unable to hot deploy a Spring or BLueprint XML file on JBoss Fuse 6.0.0

    Rich Bonneau Newbie

      Been running JBoss Fuse 6.0.0 on both windows and unix (RHEL 6.2).

      Can take a simple Spring or Blueprint with only a bean definition and when dropped into the deploy

      folder of the JBoss Fuse installation, things work fine under windows but same xml file(s) will

      fail on Unix/Linux with the following error message

       

      Error starting up bundle .... PlainAndSimple-context.xml ...

      Bundle exception Unresolved constraint in bundle PlainAndSimple-context.xml

      Unable to resolve missing requirement osgi.wiring.package; (osi.wiring.package=com.fusesource.training.jar)

       

      The context file is simply:

       

      <?xml version="1.0" encoding="UTF-8"?>

      <beans xmlns="http://www.springframework.org/schema/beans"

             xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

             xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd">

       

       

          <bean id="plainAndSimple" class="com.fusesource.training.jar.PlainAndSimple">

              <property name="simpleMessage" value="Hola, senor."/>

          </bean>

       

       

      </beans>

       

      The same project on WIndows works fine when I drop this into the deploy folder.

       

      Also I created a blueprint equivalent to the above and got the same results on the WIndows side (worked)

      and unix side (failed with same messages)

       

      Finally created a blueprint context file with ONLY a camelContext element and that worked in BOTH platforms.

       

      Help!

       

      Thanks,

      Rich