0 Replies Latest reply on Jul 25, 2013 7:39 AM by Poonam Kamboj

    rhq-agent blacklists platform resources but does not re-discover them

    Poonam Kamboj Newbie

      I am trying following configuration:

       

      JON 3.1.2,

      rhq-enterprise-agent-4.4.0.JON312GA.jar

      RHEL6 machines

      EAP 6.1

       

      Whenever agent starts, I can add RHEL6 m/c to inventroy but do not see, CPU,File systems resources. When i run discovery -f then i get following warning:

       

      "Discovery will not be run for the following ResourceTypes, because they are blacklisted: [{Platforms}File System, {Platforms}Network Adapter, {RHQAgent}RHQ Agent JVM, {Platforms}CPU, {Apache}Apache Virtual Host]"

       

      I run again discovery --blacklist=clear on agent console, then it says blacklist is cleared.

       

      but after some time again it doesnt discover File Systems and CPUs. I can see the same added to blacklist again.

       

      I have tried even restarting agent and doing uninventory and then re inventory on machines but still no luck.

       

      Please help me on the same.