0 Replies Latest reply on Jul 26, 2013 6:55 AM by pnn

    Problem with container managed testing after switching to a new version

    pnn Newbie

      Hello,

      I am using JBoss 7.1.1.Final and everything worked fine with this dependency:

       

      <dependency>

           <groupId>org.jboss.as</groupId>

           <artifactId>jboss-as-arquillian-container-managed</artifactId>

           <version>7.1.1.Final</version>

      </dependency>

       

       

      But now I wanted to switch to:

      <dependency>

           <groupId>org.wildfly</groupId>

           <artifactId>wildfly-arquillian-container-managed</artifactId>

           <version>8.0.0.Alpha4-SNAPSHOT</version>

      </dependency>


      Is there anything important I am missing?

      The server is booting correctly but arquillian won't start the deployment. I already looked into the code of arquillian and couldn't find what what I may have to change in my configuration.

      My configuration in the arquillian.xml is really simple:

      <container qualifier="jbossas_managed_local" default="true">

           <configuration>

                <!-- Find possible configuration parameters here: https://docs.jboss.org/author/display/ARQ/JBoss+AS+7.1%2C+JBoss+EAP+6.0+-+Managed -->

                <property name="jbossHome">${arquillian.jboss.home}</property>

                <property name="javaVmArguments">-Xms128M -Xmx1224M -XX:MaxPermSize=512M -Xdebug

                      -Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n

                </property>

           </configuration>

      </container>

       

      Maybe someone could give me a hint ... many thanks in advance.

       

      edit: I also tried wildfly-8.0.0.Alpha3 but had the same problem.