9 Replies Latest reply on Dec 24, 2013 8:55 PM by Tadayoshi Sato

    Eclipse Tooling sometimes hangs up...

    Tadayoshi Sato Novice

      Hello folks,

       

      In my Eclipse environment, SwitchYard Visual Editor sometimes hangs up / freezes when opening switchyard.xml and the entire IDE becomes unworkable. Once it hangs up, the Eclipse process cannot be terminated just by closing the window; I need to 'kill -9' against the process.

       

      This issue is really annoying for me. It makes me even feel like abandoning the tooling and going back to handwriting switchyard.xml ...

       

      Here is the information about my environment:

        OS: Fedora 17 (3.9.10-100.fc17.x86_64)

        JVM: 1.7.0_b147-icedtea (java-1.7.0-openjdk.x86_64  1:1.7.0.3-2.1.fc17.6)

        Eclipse: Version: 4.2.2, Build id: M20130204-1200

        SwitchYard Tools: Version: 1.0.0.v20130610-2034-H331-CI

      I installed the tooling from this update site: http://download.jboss.org/jbosstools/updates/integration/juno/integration-stack/

       

      Is this a known issue? Or has no one else experienced such an issue?

       

      To be honest, I've been suffering this issue for long time, which made me away from this otherwise great visual tooling and prefer handwriting switchyard.xml. With the release of 1.0 it's appeared to be resolved and workable for me, but the nightmare returns again ...

       

      I'd love if anyone can share the same experience or shed some light on how to resolve it permanently.

       

      Many thanks and best regards,

      Tadayoshi

        • 1. Re: Eclipse Tooling sometimes hangs up...
          Keith Babo Master

          I install and use our Eclipse tooling on a regular basis (use = every day, install = once every couple weeks for demo/test purposes) and I have never seen this issue before.  Have you installed other plugins in addition to the SwitchYard tooling?  Are you starting from a clean Eclipse base here, or have you upgraded SY tooling in the same Eclipse install for a while now (e.g. 0.6, 0.7, ...)?

          • 2. Re: Eclipse Tooling sometimes hangs up...
            Rob Cernich Master

            Hey Tadayoshi,

             

            I haven't experienced this problem either.  Is there any way you could connect a debugger to the process (e.g. JConsole) to determine if there is a deadlock?  Without being able to reproduce the problem, it's really difficult to determine what the issue is.

             

            Sorry I can't be of more help.

            Rob

            • 3. Re: Eclipse Tooling sometimes hangs up...
              Tadayoshi Sato Novice

              Hi Keith,

               

              Thanks for your comment. What OS are you using regularly?  It feels like the issue is specific to Linux (or Fedora) and I don't think it occurs on Mac or Windows.

               

              > Have you installed other plugins in addition to the SwitchYard tooling?

               

              Yes, I've installed a bunch of other plugins, say, several of JBoss Tools, EGit, Subversive, Maven Integration (m2e), Ivy Integration (IvyDE),  Scala IDE, Clojure (Counterclockwise), etc., etc.

               

              > Are you starting from a clean Eclipse base here, or have you upgraded SY tooling in the same Eclipse install for a while now (e.g. 0.6, 0.7, ...)?

               

              Starting from a clean Eclipse SDK 4.2.2, I first installed many of the above other plugins, then I tried SY tooling 0.7. As described above, I met this issue (completely unworkable) at that time so uninstalled it to go back to handwriting. This time I installed the tooling 1.0 and it's working, but sometimes it hangs up again.

               

              Thanks.

              • 4. Re: Eclipse Tooling sometimes hangs up...
                Keith Babo Master

                I use the tooling on OS X and Fedora.  We have done bootcamps with a mix of everything and the only time I've heard about this type of issue is when other plugins are around which conflict with the SY tooling.  Both SOA labs at Summit were on RHEL and there were no issues with stability of the tooling.

                 

                My recommendation would be to get a fresh install of Kepler and then install the SY 1.0.0.Final tooling *only* into that install.  Older versions of the tooling work and are stable, but if you see this with the latest tooling then it makes debugging easier.  Once we confirm you're stable in that setup, we can look to introduce other plugins and see what breaks.

                • 5. Re: Eclipse Tooling sometimes hangs up...
                  Tadayoshi Sato Novice

                  Hi Rob,

                   

                  Thanks for your inputs. I took thread dumps (attached) for the Eclipse process, however I couldn't find any deadlock. I will try using JConsole.

                   

                  One thing I noticed was when I launched Eclipse from the terminal and it hanged up I observed the following error messages displayed on the console.

                   

                  ** (Eclipse:31815): CRITICAL **: atk_object_initialize: assertion `ATK_IS_OBJECT (accessible)' failed
                  
                  
                  ** (Eclipse:31815): CRITICAL **: atk_object_initialize: assertion `ATK_IS_OBJECT (accessible)' failed
                  
                  
                  ** (Eclipse:31815): CRITICAL **: atk_object_initialize: assertion `ATK_IS_OBJECT (accessible)' failed
                  
                  
                  ** (Eclipse:31815): CRITICAL **: atk_object_initialize: assertion `ATK_IS_OBJECT (accessible)' failed
                  
                  • 6. Re: Eclipse Tooling sometimes hangs up...
                    Tadayoshi Sato Novice

                    Hi Keith,

                     

                    Thank you for the guide. OK, I will try the tooling with a latest vanilla Eclipse installation and see if the issue is still reproduced.

                    • 7. Re: Eclipse Tooling sometimes hangs up...
                      Tadayoshi Sato Novice

                      A quick update. I installed the SY tooling 1.0.0 on a clean Eclipse 4.3 installation and the same issue happened... Next I will try a different Fedora installation.

                       

                      Meanwhile, do you have any recommendation on the eclipse.ini configuration?  Do you think the default eclipse.ini would suffice for the tooling?

                      • 8. Re: Eclipse Tooling sometimes hangs up...
                        Rob Cernich Master

                        You might bump up your permspace and max heap sizes.  That said, I recently ran a base Kepler JEE install + SwitchYard without any problem using the default ini file.  I'm on RHEL 6 using Oracle JDK 6.

                        • 9. Re: Eclipse Tooling sometimes hangs up...
                          Tadayoshi Sato Novice

                          Just to close the circle, I finally reinstalled my OS and since then haven't experienced the same issue again. There must have been something wrong in my previous OS installation. Now the SY tooling works like a charm and I really like this tooling

                           

                          Anyway, thank you Keith and Rob for your advices!