3 Replies Latest reply on Apr 29, 2015 12:54 PM by Guillermo Villavicencio

    fmc not working on child container

    Mason Tran Newbie

      Hello everyone,

       

      I am facing some issues with fmc not working on its own child container.  fmc works perfectly fine, if I install it on root, but when I create a child container and put fmc on it, then the fmc url doesn't work.  I don't see any error in fuse.log file.

       

       

      JBossFuse:karaf@root> fabric:container-list

      [id]                           [version] [alive] [profiles]                     [provision status]

      root*                          1.0       true    fabric, fabric-ensemble-0000-1, jboss-fuse-full success

        fmc                          1.0       true    fmc                            success

       

       

      fmc url

      http://localhost:8181/index.html#/welcome

       

      Any help will be greatly appreciated.

       

      Mason Tran

        • 1. Re: fmc not working on child container
          Stan Lewis Novice

          Yeah, in this version child containers unfortunately use the same jetty port as the parent container.  So for the child container you need to modify the org.osgi.http.service.http.port property (more details: https://ops4j1.jira.com/wiki/display/paxweb/Basic+Configuration)

           

          You can either modify the etc/org.ops4j.pax.web.cfg file on the child, but a better solution might be to create a profile specific for that child container, in that profile add "org.ops4j.pax.web.properties" and in that properties file add:

           

          org.osgi.http.service.http.port=8282

           

          Apply that profile to the container (there's a chance with Jetty you may need to restart the child container) and then FMC should be available at "http://localhost:8282".

           

          Should mention in the next release fabric will include a port service that helps ensure that child containers don't use ports that are going to conflict with other containers.

          • 2. Re: fmc not working on child container
            Mason Tran Newbie

            Hello Stan,

             

            Thank you very much for your quick reply, your post really help me out.

             

             

            I tried adding the port number to "org.ops4j.pax.web.cfg", but it was still not working.  I guess maybe because fuse was running as fabric server, it is not using this file, I am not sure.

             

             

            So here is what I did in order for it to work:

             

            1.          JBossFuse:karaf@root> fabric:container-connect fmc_container

            2.          Put in the admin User ID / Password

            3.          admin@fmc_container> config:list

            4.          Look for "org.ops4j.pax.web" from the above command output, if you don't find it then type "exit" to get back out to the parent console.

            5.          JBossFuse:karaf@root> fabric:profile-edit -p org.ops4j.pax.web/org.osgi.service.http.port=8282 fmc

            6.          http://localhost:8282/index.html#/signin

            • 3. Re: fmc not working on child container
              Guillermo Villavicencio Newbie

              It should say:

               

              org.osgi.service.http.port=8282


              instead of


              org.osgi.http.service.http.port=8282