3 Replies Latest reply on Aug 2, 2013 2:45 AM by Bond Chan

    SecurityDomain Deployment

    Bond Chan Novice

      Hi

       

      I'm using JBoss Messaging 1.4.8.SP9(Jboss EAP 5.2.0), there having a default security-domain 'messaing' in ${jboss_home}/server/default/deploy/messaging/messaging-jboss-beans.xml,

      and refered by SecurityStore configed in the same file  which works perfectly.

       

      But when I move this to security-domain 'messaging' to another file ${jboss_home}/server/default/conf/login-config.xml with all my other security-domains on our test box, which not work, what confuse me is it works on my IDE.

       

       

      Any mis-config of my test box my lead to this issue?

        • 1. Re: SecurityDomain Deployment
          Bond Chan Novice

          ===errror log===

          2013-07-31 17:33:11,825 ERROR [org.jboss.security.auth.spi.UsersRolesLoginModule] (http-172.20.20.128-8080-3:) Failed to load users/passwords/role files

          java.io.IOException: No properties file: users.properties or defaults: defaultUsers.properties found

                  at org.jboss.security.auth.spi.Util.loadProperties(Util.java:201)

                  at org.jboss.security.auth.spi.UsersRolesLoginModule.loadUsers(UsersRolesLoginModule.java:201)

                  at org.jboss.security.auth.spi.UsersRolesLoginModule.createUsers(UsersRolesLoginModule.java:215)

                  at org.jboss.security.auth.spi.UsersRolesLoginModule.initialize(UsersRolesLoginModule.java:142)

                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

                  at java.lang.reflect.Method.invoke(Method.java:597)

                  at javax.security.auth.login.LoginContext.invoke(LoginContext.java:756)

                  at javax.security.auth.login.LoginContext.access$000(LoginContext.java:186)

                  at javax.security.auth.login.LoginContext$4.run(LoginContext.java:683)

                  at java.security.AccessController.doPrivileged(Native Method)

                  at javax.security.auth.login.LoginContext.invokePriv(LoginContext.java:680)

                  at javax.security.auth.login.LoginContext.login(LoginContext.java:579)

                  at org.jboss.security.plugins.auth.JaasSecurityManagerBase.defaultLogin(JaasSecurityManagerBase.java:553)

                  at org.jboss.security.plugins.auth.JaasSecurityManagerBase.authenticate(JaasSecurityManagerBase.java:487)

                  at org.jboss.security.plugins.auth.JaasSecurityManagerBase.isValid(JaasSecurityManagerBase.java:365)

                  at org.jboss.security.plugins.JaasSecurityManager.isValid(JaasSecurityManager.java:160)

                  at org.jboss.security.integration.JBossSecuritySubjectFactory.createSubject(JBossSecuritySubjectFactory.java:90)

                  at org.jboss.resource.connectionmanager.BaseConnectionManager2.getSubject(BaseConnectionManager2.java:687)

                  at org.jboss.resource.connectionmanager.BaseConnectionManager2.allocateConnection(BaseConnectionManager2.java:495)

                  at org.jboss.resource.connectionmanager.BaseConnectionManager2$ConnectionManagerProxy.allocateConnection(BaseConnectionManager2.java:941)

                  at org.jboss.resource.adapter.jms.JmsSessionFactoryImpl.allocateConnection(JmsSessionFactoryImpl.java:395)

                  at org.jboss.resource.adapter.jms.JmsSessionFactoryImpl.createTopicSession(JmsSessionFactoryImpl.java:167)

                  at com.lombardrisk.f3.jms.ServerJMSHelper.publishObjectToTopic(ServerJMSHelper.java:170)

          • 2. Re: SecurityDomain Deployment
            Bond Chan Novice

            Seems the problem is:

             

            in <bean name="SecurityStore" class="org.jboss.jms.server.jbosssx.JBossASSecurityMetadataStore">

             

            <property name="securityDomain">java:/jaas/messaging</property> //works in my IDE, not works in my test box

            vs

            <property name="securityDomain">messaging</property>  //works in my test box

            • 3. Re: SecurityDomain Deployment
              Bond Chan Novice

              in my test box, still works when I change SecurityDomain from messaging to java:/jaas/messaging via JMX-Consloe, seem the deployment order matters.