0 Replies Latest reply on Aug 2, 2013 2:37 PM by john pour

    Configure PicketLink 1.0.4.Final on JBOSS 7.1.1

    john pour Newbie

      I am given a requirement to upgrade our existing Seam based application to JBOSS version 7.1.1. The Seam version we are using is 2.2.1.CR2. Our application uses Picket Link version 1.0.4.final. You can see the "picketlink-seam" dependency in POM.xml file at this link http://pastebin.com/1ZVB0TtF. The PicketLink is using SAMLV2 federation protocol to facilitate OpenID SSO .Our old application was running on JBOSS 5.1.0.GA. The PicketLink and SAMLV2 was configured using "external-authentication-config.xml" and "saml-entities.xml" files. I need to move these configurations to JBOSS 7.1.1. I tried putting those files in WEB-INF/classes hoping they will be read through classpath. But I don't think those files are read as during deployment WS-TRUST kicks in and it tries to look for a WSDL file.

       

      So, my question is if there's any documentation on how to configure PicketLink 1.0.4.Final to run on JBOSS 7.1.1.

       

      Thanks.