3 Replies Latest reply on Aug 6, 2014 2:31 AM by Swapna S

    zookeeper connection refused

    Mason Tran Newbie

      Hello everyone,

       

      I find that the JBoss Fuse Server is easy to break.  For whatever reason if something goes wrong, seems like it cannot recover itself even after a restart.  The system that I configure was working prefectly fine.  I tried to deploy a camel project from Fuse IDE into JBoss Fuse Fabric > root > camel.  Deployment when fine, but the project was not able to run because of some Maven dependencies were missing.  In the "Fuse Management Console" I see that provisioning of root was failed after the Camel project was deploy, it went from "yellow" to "red".  So I corrected the Maven dependence problem and restarted JBoss Fuse Server and the "Fuse Management Console" doesn't work any more.

       

      So I go into my Fuse command window and try to run some fabric command.  And I get error saying "Command not found".

       

      JBossFuse:karaf@root> fabric:container-list

      Command not found: fabric:container-list

      JBossFuse:karaf@root>

       

      I have a backup of the whole jboss-fuse-6.0.0.redhat-024 directory before I start the Camel deployment process from Fuse IDE.  So I completely remove "jboss-fuse-6.0.0.redhat-024" and recreate this directory from my back up zip file.  And I restart the JBoss Fuse Server, and it is still not working.  I keep on getting error connecting to Zookeeper.  I am using the Zookeeper that came with JBoss Fuse.

       

      I also find it weird is that if you stop JBoss Fuse server, the Zookeeper instance will still be running.  I have have to manually kill it.

       

      Few things I can think of that might fix my problem, either delete the "\jboss-fuse-6.0.0.redhat-024/data" directory restart JBoss Fuse and let it recreate itself again.  Or maybe I have to reinstall JBoss Fuse again and recreate the fabric.  Is it safe to delete "data" folder and let it recreate again after the system gone live?

       

      Any help will be greately appreciated.

       

      Fuse Management Console URL:

      http://localhost:8181/index.html#/signin

         

       

      Error from fuse.log file:

      16:55:06,067 | INFO  | hat-024-thread-1 | ZooKeeper                        | 53 - org.fusesource.fabric.fabric-linkedin-zookeeper - 7.2.0.redhat-024 | Initiating client connection, connectString=99hrnap03.dmz.dev.lab:2181 sessionTimeout=30000 watcher=org.linkedin.zookeeper.client.WatcherChain@17df503b

      16:55:06,081 | INFO  | d-1-SendThread() | ClientCnxn                       | 53 - org.fusesource.fabric.fabric-linkedin-zookeeper - 7.2.0.redhat-024 | Opening socket connection to server /10.12.3.198:2181

      16:55:06,085 | INFO  | mz.dev.lab:2181) | ZooKeeperSaslClient              | 53 - org.fusesource.fabric.fabric-linkedin-zookeeper - 7.2.0.redhat-024 | Client will not SASL-authenticate because the default JAAS configuration section 'Client' could not be found. If you are not using SASL, you may ignore this. On the other hand, if you expected SASL to work, please fix your JAAS configuration.

      16:55:06,089 | WARN  | mz.dev.lab:2181) | ClientCnxn                       | 53 - org.fusesource.fabric.fabric-linkedin-zookeeper - 7.2.0.redhat-024 | Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect

      java.net.ConnectException: Connection refused

                at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)[:1.6.0_22]

                at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:592)[:1.6.0_22]

                at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:286)[53:org.fusesource.fabric.fabric-linkedin-zookeeper:7.2.0.redhat-024]

                at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1035)[53:org.fusesource.fabric.fabric-linkedin-zookeeper:7.2.0.redhat-024]

       

      Thanks,

      Mason Tran

        • 1. Re: zookeeper connection refused
          Stan Lewis Novice

          Use fabric:profile-refresh to make the fabric agent re-provision a profile, there's no need to restart the entire container.

           

          From the sound of the way you've set things up the ZooKeeper server would be running in the container that you've installed FMC in, so restarting/wiping the data directory of that container will effectively delete your ZooKeeper server configuration, meaning you'd have to re-create your fabric if you delete the data directory or the installation.  BTW it's enough to just stop the container and delete the data directory to clean up and re-create your fabric if need be.

          • 2. Re: zookeeper connection refused
            Mason Tran Newbie

            Thanks Stan for the reply.

            • 3. Re: zookeeper connection refused
              Swapna S Newbie

              I'm facing the same issue in JBossFuse6.1. I have created 6 fabric child containers and deployed application in each of the node in active/passive mode. I received OutofMemory exception in one of my application. Once after I fixed it, I started getting "fabric command not found" exception.

              JBossFuse:karaf@root> fabric:container-list

              Command not found: fabric:container-list

               

              Now, If I delete the data directory, do I need to create fabric containers and deploy application from the scratch. or If I stop the container,delete data dir, and start container will it pick up automatically.