1 Reply Latest reply on Sep 9, 2013 9:44 AM by Alessio Soldano

    Registering interceptors with annotation do not work.

    wolowizard Newbie

      Hi.

       

      I am using a Jboss EAP 6.0 and am trying to get interceptors to work, but am struggling.

       

      The EAP I am using is not modified, except for an jdbc library and a security realm setting.

       

      I have followed the example given in http://www.mastertheboss.com/jboss-web-services/installing-apache-cxf-on-jboss-as

       

      But when I run the example, there is no logging done. I have also tried to write som custom interceptors just to try, but nothing happens. When I TRACE the server log, I can't see any interceptors added by cxf.

       

      Anyone had this problem? Any config files I am missing?

       

      Thanks in advance.

        • 1. Re: Registering interceptors with annotation do not work.
          Alessio Soldano Master

          Hi,

          the document you linked basically refers to an old version of the community application server, while you have EAP 6 here.

          Generally speaking, you don't need to run the jbossws installer for having Apache CXF functionalities, as they're already available to you by adding a dependency to the org.apache.cxf module to your deployment (either in the MANIFEST.MF or in a proper jboss-deployment-structure.xml descriptor). You might want to create a org.springframework.spring module if you really need Spring functionalities, but that's not required at all.

          This said, there're many examples in jbossws testsuite (and documentation) making use of Apache CXF interceptors.

          You need to provide more details on your deployment to try understanding what might be missing.