3 Replies Latest reply on Aug 27, 2013 5:27 AM by Santy Avinash

    Not able to connect remotely for administration on Port 9990

    Santy Avinash Newbie

      Hi,

       

      I am trying to set monitoring for Jboss from remote monitoring application. But I am not able to connect on port 9990 etc

       

      I went on the Jboss server and tried to telnet on the IP address on port 9990 but it does not work, but I can telnet to localhost on port 9990.

       

      My standalone .xml has following config

       

       

      <interfaces>

              <interface name="management">

                  <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>

              </interface>

              <interface name="public">

                  <inet-address value="${jboss.bind.address:127.0.0.1}"/>

              </interface>

             <!-- TODO - only show this if the jacorb subsystem is added  -->

              <interface name="unsecure">

                  <!--

                    ~  Used for IIOP sockets in the standard configuration.

                    ~                  To secure JacORB you need to setup SSL

                    -->

                  <inet-address value="${jboss.bind.address.unsecure:127.0.0.1}"/>

              </interface>

          </interfaces>

          <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}">

              <socket-binding name="management-native" interface="management" port="${jboss.management.native.port:9999}"/>

              <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>

              <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9443}"/>

              <socket-binding name="ajp" port="8009"/>

              <socket-binding name="http" port="8080"/>

              <socket-binding name="https" port="8443"/>

              <socket-binding name="osgi-http" interface="management" port="8090"/>

              <socket-binding name="remoting" port="4447"/>

              <socket-binding name="txn-recovery-environment" port="4712"/>

              <socket-binding name="txn-status-manager" port="4713"/>

              <outbound-socket-binding name="mail-smtp">

                  <remote-destination host="localhost" port="25"/>

              </outbound-socket-binding>

          </socket-binding-group>


      We start the Jboss with -b (Prod IP address)


      I tried to add another interface to standalone that xml


      <interface name="any">

      <any-ipv4-address/>

      </interface>


      and changed socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:0}" to

      socket-binding-group name="standard-sockets" default-interface="any" port-offset="${jboss.socket.binding.port-offset:0}">


      restarted the application with -b 0.0.0.0 but still not able to connect on port 9990

       

      In the logs I can see "Admin console listening on http://127.0.0.1:9990"


      Help will be appreciated.


      Regards


      Santosh