9 Replies Latest reply on Aug 30, 2013 5:27 PM by Justin Bertram

    Publish JMS Message from on JBOSS AS to JMS Server in another JBOSS AS

    William Moore Newbie

      I have tried to follow information from this site:  http://lukaszantoniak.wordpress.com/2012/12/11/jboss-as-7-remote-jms-queue/

       

      <connector name="remote-jms-nonmgmt">

          <factory-class>org.hornetq.core.remoting.impl.netty.NettyConnectorFactory</factory-class>

           <param key="host" value="168.179.60.173"/>

           <param key="port" value="5445"/>

      </connector>

      <netty-connector name="remote-jms-mgmt" socket-binding="remote-jms-binding"/>

       

      The ip address is the address of the JBOSS AS7 with hornetq and topics

       

      I also added the following to the jms-connection-factories:

       

                     <connection-factory name="ConnectionFactory1NonMgmt">

                             <connectors>

                                <connector-ref connector-name="remote-jms-nonmgmt"/>

                             </connectors>

                             <entries>

                                <entry name="java:/ConnectionFactory1NonMgmt"/>

                             </entries>

                          </connection-factory>

                          <pooled-connection-factory name="ConnectionFactory1Mgmt">

                             <user>billhmoore</user>

                             <password>pebhup2012</password>

                             <connectors>

                                <connector-ref connector-name="remote-jms-mgmt"/>

                             </connectors>

                             <entries>

                                <entry name="java:/ConnectionFactory1Mgmt"/>

                             </entries>

                          </pooled-connection-factory>

       

      I have also added the following to socket-binding-group:

       

          <outbound-socket-binding name="remote-jms-binding">
              <remote-destination host="168.179.60.173" port="5445"/>
          </outbound-socket-binding>

      When I run the webapp in a JBOSS AS7, I get the following:

       

      13:16:39,904 DEBUG [org.jboss.naming.remote.server.RemoteNamingService] (Remoting "sedws-d1lf-0v13" task-1) Channel Opened - Channel ID 13eda06c (inbound) of Remoting connection 4c45a3ad to /168.179.145.226:50216

      13:16:39,935 DEBUG [org.jboss.naming.remote.server.RemoteNamingService] (Remoting "sedws-d1lf-0v13" task-3) Chosen version 0x01

      13:16:39,959 DEBUG [org.jboss.as.ejb3.remote.EJBRemoteConnectorService] (Remoting "sedws-d1lf-0v13" task-2) Client with protocol version 1 and marshalling strategy river trying to communicate on Channel ID 05908c4e (inbound) of Remoting connection 4c45a3ad to /168.179.145.226:50216

      13:16:39,965 DEBUG [org.jboss.as.ejb3.remote.protocol.versionone.VersionOneProtocolChannelReceiver] (Remoting "sedws-d1lf-0v13" task-2) Sending initial module availability message, containing 2 module(s) to channel Channel ID 05908c4e (inbound) of Remoting connection 4c45a3ad to /168.179.145.226:50216

       

      host sure were the ip: 168.179.145.226 is coming from.

       

      I attempt to get the topic using "java:/topic/whm_dev_ATRInboundTopic" and get the following error:

       

      13:16:39,970 ERROR [stderr] (MSC service thread 1-13) javax.naming.NameNotFoundException: topic/whm_dev_ATRInboundTopic -- service jboss.naming.context.java.topic.whm_dev_ATRInboundTopic