0 Replies Latest reply on Aug 30, 2013 2:07 PM by kelly goedert

    jboss 7.1.1 cluster problem with mod_cluster

    kelly goedert Apprentice

      Hi,

       

      I am trying to setup a jboss 7.1.1 cluster following this guide here http://blog.c2b2.co.uk/2013/02/setting-up-jboss-eap-6-cluster-with.html#comment-form

      But when I tried to access http://localhost:6666/mod_cluster_manager it was unavailable. Then I found this post here on the forum mod_cluster 1.2 + JBossAS 7.1 problem and I did the suggested configurations of AdvertiseSecurityKey on both jboss and apache, and added added instance-id="${jboss.node.name}" to web module in stanalone.xml in both nodes. Now when I access mod_cluster manager, I can see both nodes like this

       

      Node server2 (ajp://127.0.0.1:8109):

      Enable Contexts Disable Contexts

      Balancer: mycluster,LBGroup: ,Flushpackets: Off,Flushwait: 10000,Ping: 10000000,Smax: 26,Ttl: 60000000,Status: OK,Elected: 8,Read: 190444,Transferred: 0,Connected: 0,Load: 100

      Virtual Host 1:

      Contexts:

      /, Status: ENABLED Request: 0 Disable /ClusteredJSF-1.0, Status: ENABLED Request: 0 Disable 

      Aliases:

      default-host localhost example.com 

      Node server1 (ajp://127.0.0.1:8009):

      Enable Contexts Disable Contexts

      Balancer: mycluster,LBGroup: ,Flushpackets: Off,Flushwait: 10000,Ping: 10000000,Smax: 26,Ttl: 60000000,Status: OK,Elected: 7,Read: 1010,Transferred: 0,Connected: 0,Load: 100

      Virtual Host 1:

      Contexts:

      /ClusteredJSF-1.0, Status: ENABLED Request: 0 Disable 

      Aliases:

      example.com localhost default-host 

       

      So I expected that accessing now http://localhost/ClusteredJSF-1.0 gives me a 404 error.

       

      Can anybody help?

       

      Thanks