0 Replies Latest reply on Sep 4, 2013 4:18 PM by Mike schwery

    setting up eclipselink-1.1.2 in jboss 7.1

    Mike schwery Novice

      I'm trying to get eclipselink-1.1.2 working in JBoss 7.1 without any luck.

      I've created a modules directory and module.xml file for eclipselink.

       

      The module.xml looks like

      <?xml version="1.0" encoding="UTF-8"?>
      <module xmlns="urn:jboss:module:1.1" name="org.eclipse.persistence">
        <resources>
          <resource-root path="eclipselink-1.1.2.jar"/>
        </resources> 
      </module>

       

      MY persistence.xml looks like.

      <?xml version="1.0" encoding="UTF-8" ?>
      <persistence xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_2_0.xsd"
        version="2.0" xmlns="http://java.sun.com/xml/ns/persistence">
         <persistence-unit name="EmployeeService" transaction-type="JTA">
          <provider>org.eclipse.persistence.jpa.PersistenceProvider</provider>
          <jta-data-source>java:jboss/TestappDS</jta-data-source>
          
        
         <class>jpa.Employee</class> 
          
         <exclude-unlisted-classes>true</exclude-unlisted-classes>
          <properties>
            <property name="javax.persistence.jdbc.driver" value="org.h2.Driver" />
            <property name="javax.persistence.jdbc.url" value="jdbc:h2:mem:teste" />
            <property name="javax.persistence.jdbc.user" value="sa" />
            <property name="javax.persistence.jdbc.password" value="sa" />

       

            <!-- EclipseLink should create the database schema automatically -->
            <property name="eclipselink.ddl-generation" value="create-tables" />
            <property name="eclipselink.ddl-generation.output-mode" value="database" />
          </properties>

       

        </persistence-unit>
      </persistence>

       

      Can anyone give me suggestions.