5 Replies Latest reply on Sep 12, 2013 9:39 AM by pnn

    ARQ tests won't run on eap 6.1

    pnn Newbie

      Hello,

      I have arquillian tests that will be executed by a jenkins job. When I'm using JBoss 7.1.1 everything runs fine, but when I switch to JBoss eap 6.1 I'll get the following error:

       

      java.lang.IllegalStateException: Error launching test at http://0.0.0.0:8080/test/ArquillianServletRunner?outputMode=serializedObject&className=testClass&methodName=testMethod&cmd=event. Got 503 (Service Unavailable)

      at org.jboss.arquillian.protocol.servlet.ServletMethodExecutor.execute(ServletMethodExecutor.java:214)

      at org.jboss.arquillian.protocol.servlet.ServletMethodExecutor$1.run(ServletMethodExecutor.java:243)

      at java.util.TimerThread.mainLoop(Timer.java:555)

      at java.util.TimerThread.run(Timer.java:505)

       

      Maybe someone could help me because I have no idea why it doesn't work on eap 6.1.

      I don't know what further information could be helpful, because I have no idea what could cause this error.

       

      I am using the following arq dependencies

                  <!-- Arquillian -->

                  <dependency>

                      <groupId>org.jboss.spec</groupId>

                      <artifactId>jboss-javaee6-specs-bom</artifactId>

                      <version>2.0.0.Final</version>

                      <type>pom</type>

                      <scope>test</scope>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.arquillian.junit</groupId>

                      <artifactId>arquillian-junit-container</artifactId>

                      <version>1.1.1.Final</version>

                      <scope>test</scope>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.arquillian.protocol</groupId>

                      <artifactId>arquillian-protocol-servlet</artifactId>

                      <version>1.1.1.Final</version>

                      <scope>test</scope>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.as</groupId>

                      <artifactId>jboss-as-arquillian-container-managed</artifactId>

                      <version>${version.org.jboss.jbossas}</version>

                      <scope>test</scope>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.as</groupId>

                      <artifactId>jboss-as-arquillian-container-remote</artifactId>

                      <version>${version.org.jboss.jbossas}</version>

                      <scope>test</scope>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.arquillian.extension</groupId>

                      <artifactId>arquillian-persistence-impl</artifactId>

                      <version>1.0.0.Alpha5</version>

                      <scope>test</scope>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.shrinkwrap.resolver</groupId>

                      <artifactId>shrinkwrap-resolver-bom</artifactId>

                      <version>2.0.0</version>

                      <scope>test</scope>

                      <type>pom</type>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.shrinkwrap</groupId>

                      <artifactId>shrinkwrap-api</artifactId>

                      <version>1.2.0</version>

                  </dependency>

        • 1. Re: ARQ tests won't run on eap 6.1
          Rafael Pestano Novice

          Hi there,

           

          whats is ${version.org.jboss.jbossas} value? i have no problems with eap 6.1, you can find my config in this post:Help setup functional tests with Graphene 2.x

           

          i use version 7.1.3 in container version.

           

          <dependency>

                          <groupId>org.jboss.as</groupId>

                          <artifactId>jboss-as-arquillian-container-managed</artifactId>

                          <version>7.1.3.Final</version>

                          <scope>test</scope>

                      </dependency>

           

          maybe it helps.

          • 2. Re: ARQ tests won't run on eap 6.1
            pnn Newbie

            Sorry, <version.org.jboss.jbossas>7.2.0.Final</version.org.jboss.jbossas> is the value of the property.

            Also If I run the tests on a EAP 6.1 server on my local machine everything works fine.


            I tried it with version 7.1.3.Final, but I get the same exception.

            • 3. Re: ARQ tests won't run on eap 6.1
              Rafael Pestano Novice

              what's the difference between your local server and the one which raises the exception?

               

              for example my local tests run in a windows machine on eap 6.1 in standalone mode but my production tests runs on  linux runing eap 6.1 in domain mode, what i have to change is just jbossHome property in arquillian.xml:

               

              <container qualifier="jbossas-managed"  default="true" >

                      <configuration>

                              <property name="jbossHome">C:\EAP-MODELO-6.1\jboss-eap-6.1</property>//local server

              <!--             <property name="jbossHome">/opt/jboss-eap-6.1</property> -->//production server

                           <property name="outputToConsole">true</property>

                          <property name="allowConnectingToRunningServer">true</property>

                      </configuration>

               

              maybe that helps

              • 4. Re: ARQ tests won't run on eap 6.1
                pnn Newbie

                I have two container defined in my arquillian.xml and set the container to arquillian.launch in the pom-file using profiles.

                My local machine is windows and the server is running on linux, both as standalone with exactly the same configuration.

                 

                Arquillian.xml:

                    <!-- Container configuration to use on local developer computers -->

                  <container qualifier="jbossas_managed_local" default="true">

                  <configuration>

                  <!-- Find possible configuration parameters here: https://docs.jboss.org/author/display/ARQ/JBoss+AS+7.1%2C+JBoss+EAP+6.0+-+Managed -->

                            <property name="jbossHome">${arquillian.jboss.home}</property>

                            <property name="javaVmArguments">-Xms256M -Xmx1536M -XX:MaxPermSize=1024M -Xdebug

                                -Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=n

                            </property>

                        </configuration>

                  </container>

                 

                  <!-- Container configuration to use on Jenkins integration server -->

                  <container qualifier="jbossas_managed_jenkins">

                  <configuration>

                  <property name="jbossHome">/datafs/proj/application_server/jboss-eap-6.1_arquillian</property>

                  <property name="javaVmArguments">-Xms128M -Xmx1224M -XX:MaxPermSize=512M -Xdebug

                                -Xrunjdwp:tr

                                ansport=dt_socket,address=8787,server=y,suspend=n

                            </property>

                  <property name="allowConnectingToRunningServer">true</property>

                  <property name="managementPort">9999</property>

                  </configuration>

                  </container>

                • 5. Re: ARQ tests won't run on eap 6.1
                  pnn Newbie

                  So finally I found a solution how to fix this problem:

                  I found out that removing<defaultProtocol type="Servlet 3.0"/> from arquillian.xml would fix this problem.

                   

                  http://stackoverflow.com/questions/18693376/arquillian-tests-fail-on-jboss-eap-6-1-but-working-on-jboss-7-1-1