1 Reply Latest reply on Sep 8, 2013 3:30 AM by Brian Leathem

    Adding rich:editor to kitchensink-rf dataTable error

    gebuh Newbie

      I built and deployed the richfaces kitchensink-rf example from jboss central for jboss 7 and RF4.

      The example page loaded and worked correctly.  I tried adding a rich:editor component to the datatable:

       <rich:dataTable id="memberTable" var="_member" value="#{members}" rendered="#{not empty members}" style="width : 100%">
                        ...
                          <rich:column id="member_email">
                            <f:facet name="header">Email</f:facet>
                            #{_member.email}
                         </rich:column>
                         <rich:column id="editor">
                         
                         <rich:editor value="#{_member.description}" />
                           
                         </rich:column>
                         <f:facet name="footer">
                            REST URL for all members: <a href="#{request.contextPath}/rest/members" target="_rest_all">/rest/members</a>
                         </f:facet>
                      </rich:dataTable>
      

       

      with a new description field added to the backing bean, the page no longer loads and I get:

      java.lang.ClassNotFoundException: org.w3c.css.sac.ErrorHandler from [Module "deployment.jboss-as-kitchensink-rf.war:main" from Service Module Loader]
      org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
      org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
      org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
      org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
      org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
      ...
      

       

      If I replace it with an h:inputText tag the page works and loads correctly.

      I've done this in RF3 with no problems - I'm new to RF4.  Is there some other configuration I'm missing?