4 Replies Latest reply on Sep 17, 2013 11:12 AM by Simon Schober

    System properties usage for authentication code

    Simon Schober Newbie

      Hello together,

       

      i have a problem using system properties for "code" replacement in the security subsystem. But first things first.

      I use the jboss 7.1.1 and the subsystem in version 1.1. I need two server instances, therefore is use the domain mode

      which is working perfectly. The only problem is that i´ve code that uses two different login modules. One for each server. My configuration in the

      domain.xml look like this:

      <subsystem xmlns="urn:jboss:domain:security:1.1">
          <security-domains>
              <security-domain name="vs">
                  <authentication>
                      <login-module code="${login.module}" flag="required" />
                  </authentication>
              </security-domain>
              ...
          </security-domains>
          ...
      </subsystem>
      

       

      I want to archive, that every server is replacing the "login.module" property with its own parameter. I´ve used this method in another project

      but somehow this is not working here. If i replace the code="" with a static parameter it works. But it´s not working with properties. Does

      anybody know why this is not working?

       

      (I tried setting the system properties at the top of the domain.xml file, at the servergroups definition and the

      server definitions in the host.xml file. I also tried to define the boot-time="true" option. None of the configurations are working.)

       

      Thanks a lot!