0 Replies Latest reply on Sep 13, 2013 8:17 AM by Ethan Hek

    Confusing problem with JBoss Tools

    Ethan Hek Newbie

      Hi, I am using Kepler + JBoss tools + AS 7.1 and have tried this on both windows 7 and ubuntu linux and had the same problem in both.

       

      Initially I created a web application using Spring and set it up using external maven.  I was running it in jetty and it worked fine.  Then I wanted to import it in to eclipse and run it on JBoss.  I did eclipse:eclipse, eclipse:clean.  Then I added a plugin to target 1.6 (so I could add the dynamic web project facet).

       

      I get the project imported into eclipse and run it on the web server, and it seems to work fine.  Except when I try to hit the app, the request never seems to go to my default servlet->controller.  There is no error, no acknowledgement that the app is even receiving the http GET request.  When I remove the path for my app and just go to localhost:8080, I see the JBoss welcome page.

       

      So then I created a new project using one of the templates from JBoss Central (the Spring MVC template).  Run it on the JBoss server and everything works perfectly.

       

      So then I created a new project in external maven using the quickstart artifact.  I copy the Spring MVC template's file structure and files exactly.  I only change things like name, finalName, and the package names according to my app.  Everything else including the pom.xml, web.xml, dispatcher/controller are exactly the same.

       

      I then try to import the project into Eclipse and run it on the JBoss server.  Same problem as with my orignal app.  It can build without error and deploy the appname.war to JBoss, but when I go to localhost:8080/appname , the app's controller is never run.

       

      I also noticed that under the target folder when I used the template, the target folder contains another folder called m2e-wpt.  However in my app and the app I tried to copy there is no m2e-wpt under the target folder.

       

      I can't think of what config file I messed up on since when I created my copy of the JBoss Central Spring MVC template, I made an exact copy of all the config files and it still didn't work.  However, for some reason eclipse is treating the orignal Spring MVC app and my copied app differently.

       

      Any help would be much appreciated as I am new and this is really frustrating.

       

      thanks