1 Reply Latest reply on Sep 17, 2013 4:59 AM by Simon Martinelli

    Unable to start server after upgrading to 4.9

    Simon Martinelli Novice

      I upgraded RHQ from 4.6 to 4.9 but now I'm no longer able to start the server:

       

      10:29:05,588 ERROR [org.rhq.enterprise.server.installer.Installer] An error occurred: org.rhq.common.jbossas.client.controller.FailureException: Failed to add new connector [https]: {"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-1" => {"JBAS014671: Failed services" => {"jboss.web.connector.https" => "org.jboss.msc.service.StartException in service jboss.web.connector.https: JBAS018007: Error starting web connector

          Caused by: LifecycleException:  JBWEB000023: Protocol handler initialization failed"}}}}

              at org.rhq.common.jbossas.client.controller.WebJBossASClient.addConnector(WebJBossASClient.java:176) [rhq-jboss-as-dmr-client-4.9.0.jar:4.9.0]

              at org.rhq.enterprise.server.installer.ServerInstallUtil.setupWebConnectors(ServerInstallUtil.java:1381) [rhq-installer-util-4.9.0.jar:4.9.0]

              at org.rhq.enterprise.server.installer.InstallerServiceImpl.install(InstallerServiceImpl.java:296) [rhq-installer-util-4.9.0.jar:4.9.0]

              at org.rhq.enterprise.server.installer.Installer.doInstall(Installer.java:117) [rhq-installer-util-4.9.0.jar:4.9.0]

              at org.rhq.enterprise.server.installer.Installer.main(Installer.java:58) [rhq-installer-util-4.9.0.jar:4.9.0]

              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_17]

              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_17]

              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_17]

              at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_17]

              at org.jboss.modules.Module.run(Module.java:262) [jboss-modules.jar:1.2.0.CR1]

              at org.jboss.modules.Main.main(Main.java:329) [jboss-modules.jar:1.2.0.CR1]

       

      Thanks for your help!

      Simon

        • 1. Re: Unable to start server after upgrading to 4.9
          Simon Martinelli Novice

          I moved a bit forward.

           

          Now rhq-server.sh start seams to work BUT i cannot access the web gui:

          Thats all I see. But coregui is not running. What is wrong?

           

           

          Welcome to EAP 6

          Your JBoss Enterprise Application Platform is running.

          Administration Console | Online User Groups

          This is early access software and is not intended for production use. Red Hat will not provide production support and will not provide patches for identified issues. Red Hat will provide limited developer-level assistance via the Customer Portal Forums. Red Hat does not commit to providing patches for this release but will consider fixes for identified issues for the GA or later release.

          To replace this page set "enable-welcome-root" to false in your server configuration and deploy your own war with / as its context path.