0 Replies Latest reply on Sep 18, 2013 12:55 PM by Marc Fournier

    jboss-as-7.2.0.Final: Deployments not retrying

    Marc Fournier Newbie

      We've recently upgraded our jBoss from 7.1.0 -> 7.2.0, and our scp deployments no longer appear to work ... everything worked great with 7.1.0, we had hudson use scp to  send across the war file to the deployments directory, and away things went ... now, with no changes on the hudson side, we are getting:

       

      Scan found incompletely copied file content for deployment /usr/local/jboss-as-7.2.0.Final/standalone/deployments/openstudent.war. Deployment changes will not be processed until all content is complete.

       

      Our standalone.xml file has the following:

       

          <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">
              <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000" deployment-timeout="1200"/>
          </subsystem>

       

      Checking our older standalone.xml file, from the 7.1.0 system, its identical:

       

          <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">
              <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000" deployment-timeout="1200"/>
          </subsystem>

       

      And they seem to be the same version scanner ... I didn't copy the standalone.xml from 7.1.0 -> 7.2.0, I manually ported over any internal settings we made over to the new config file (IPs, DB Datasources, etc), so I don't think I've introduced something that wasn't forward compatible or anything like that ...

       

      From the message, it sounds like it *should* be re-trying to deploy at some point, but doesn't appear to ever do so, except if I restart the server, when the file that is in place does get deployed without any issues ...

       

      Thoughts?   Something else I should be checking?

       

      Thanks ...