1 Reply Latest reply on Sep 25, 2013 5:58 PM by Pedro Igor

    Setting up Picketlink 2.5.1 in Jboss AS 7.1 or Wildfly

    jorge ciombalo Newbie

      Hi all,

       

      Is already possible to set up picketlink 2.5.1 in JBoss AS 7.1.1 or Wildfly? Is there any walkthroughs about it?

       

      I have tried to run the installer against the Wildfly Alpha4 and it has executed sucessfully, but I've got the following error when deploying the idp.war artifact:

      11:11:59,242 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) JBAS014613: Operation ("deploy") failed - address: ([("deployment" => "idp.war")]) - failure description: {"JBAS014771: Services with missing/unavailable dependencies" => ["jboss.undertow.deployment.default-host./idp.UndertowDeploymentInfoService is missing [jboss.security.security-domain.idp]"]}

       

      I also have tried to install (manually) against JBoss AS 7.1.1 but I haven't found any help about how to set up modules, once I think that the module's directories seems not to be the same of the installer.

       

      If anyone got succeeded performing this configuration, please help me, better if it's in Jboss AS 7.1 than Wildfly.

       

      Regards

      Jorge Ciombalo